I am new to Ubuntu, using 14.04 I am trying to format an SD card to make space on it, and it's not working. I tried in terminal:

format mmcblk0
hformat mmcblk0

and it says:

hformat: /home/michael/mmcblk0: error (no such file or directory)

How do you format an SD card?


3 Answers 3


It's very easy.

  1. First insert your SD in Sdcard Reader, let Ubuntu mount it.
    check the access path for the sd card using df You will get some output like this

    Filesystem     1K-blocks     Used Available Use% Mounted on
    /dev/sda7      104087776 76247376  22529988  78% /
    /dev/sdd1       15549952    13056  15536896   1% /media/g/3630-6335  
  2. Unmount the sd using

    sudo umount /path/to/sd/card
  3. Format the card using mkfs

    sudo mkfs.vfat -F32 -v /path/to/sd/card

-F flag is for Fat32 system.
-v flag is for being verbose

  • Hi. I just tried it and did not work, and i mount the partion as boot whit gpart, and it almost work, and it type in this at the startup I/O system error and mmcblk.
    – Michael
    May 6, 2015 at 9:36
  • @Michael can you give some error log, of the commands you are trying ? May 6, 2015 at 10:21
  • This works for me. sudo mkfs.vfat -F32 -v -I /dev/sdb
    – Yang Yu
    Aug 19, 2019 at 8:27

You can use the included Disks application

enter image description here

Click on the target partition. Now you can create new partitions, format the disk or change partition type.

  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Jun 28, 2016 at 11:15

Use the software gparted to format the partition on your sd drive

  1. Download gparted from the software centre

  2. Start it

  3. Load your sd within the software (upper right button)

  4. right click on sd partition: unmount

  5. Delete partition

  6. Create new partition fat32, label it as you like

That's it, if you have any problem write here :)

  • 1
    Hi. I tried gpart but it says unable to read input / output error on mmcblk0.
    – Michael
    May 1, 2014 at 8:46

Not the answer you're looking for? Browse other questions tagged .