0

I have a Sony USM32GM 32 GB USB Flash Drive and I can not get it to show up on any device.

I have tried it in Windows 7 Pro, and it will show up and try to install the driver, fail, and then it won't show up again unless I delete the driver, then it repeats.

I have tried it in Mac OSX 10.5.8 PPC, where, if I plug it into the USB port on the keyboard, it acknowledges it, saying that it can't get enough power. If I plug it directly into the computer, it won't show up at all, or anything.

Finally, I tried it in both my Ubuntu 12.04 LTS machine and my Zorin 6.4 LTS machine (Zorin 6 is based on Ubuntu 12.04), and it would not come up in any file manager, even under /media. I tried "lsusb" in terminal, and got:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2504 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 005 Device 002: ID 413c:2501 Dell Computer Corp. 
Bus 001 Device 000: ID 054c:02a5 Sony Corp. MicroVault Flash Drive

The last one must be it! Is there another way to access it? I just want the data, even if I can't repair it! Also, wherever and whatever it is plugged into, the green light will flash on it, like it usually does. Also, I have tried it in EVERY port on each computer, with the same result.

Edit: The results of "lsblk" are:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sr0     11:0    1  1024M  0 rom  
sda      8:0    0  74.5G  0 disk 
├─sda1   8:1    0  52.6G  0 part /media/761CEB081CEAC1EB
├─sda2   8:2    0     1K  0 part 
├─sda5   8:5    0  18.9G  0 part /
└─sda6   8:6    0     3G  0 part [SWAP]
zram0  251:0    0   1.5G  0 disk [SWAP]
sdb      8:16   1  29.1G  0 disk 

Also, I forgot to mention that I have tried Testdisk and Photorec, both of which I am familiar with, but the drive will not show up in them.

Thank You!

2
  • post the output of lsblk command in your question. Commented May 1, 2014 at 2:21
  • Look at what dmesg -T and less /var/log/kern.log* have to say about your USB drive. Edit your question and add selected parts of the data, formatted with the {} button.
    – waltinator
    Commented Jan 11, 2016 at 13:27

1 Answer 1

0

See the tool photorec.

To install it :

$ sudo apt-get install testdisk

This will install testdisk and its subcomponent photorec. testdisk is more powerful but can make you loose data, so use photorec first. photorec only reads data, so it's safe to use (By the way, you can use photorec as a user when you must be root to use testdisk).

$ photorec
$ sudo testdisk # Use that one as a second choice.

It's a console software, I hope you won't be afraid :-D.

http://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step

http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

3
  • Thank you for the suggestion, but I have already tried testdisk and photorec, both of which I have used before and am pretty familiar with, but the drive wouldn't show up in either of them. Commented May 1, 2014 at 2:48
  • Well if photorec didn't detect it, it sucks pretty much. Are you sure you choose the right filesystem, scan, option...? Maybe you can do a raw backup (using dd) and then try some foolish testdisk option? ... Nevermind, I'm stupid. Commented May 1, 2014 at 2:49
  • Thank you for trying to help! You are not stupid! You made a very good suggestion! I just wish I could get to the point of choosing a file system, but all that shows up for a drive to select is my hard drive. Commented May 1, 2014 at 3:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .