I know there is plenty of documentation on blacklisting the Nouveau driver. However the normal methods are not working for me. I tried adding the below lines in the /etc/modprobe.d/blacklist.conf file, however this does not work. Nouveau still gets loaded anyway.

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

I tried to disable the kernel modules using this command:

echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf

followed by:

update-initramfs -u

but it doesn't work. Nouveau still gets loaded anyway.

  • I did it yesterday... did you reboot? check this out: askubuntu.com/questions/457850/… – Wagner Patriota May 1 '14 at 1:09
  • @Wagner Patriota Yes I did a reboot. I however do not see how that link applies as I am not having problems getting the nvidia driver working. I can not even blacklist nouveau. I haven't installed any propriety drivers yet as nouveau has to be blacklisted first. – Sandman007 May 1 '14 at 1:15
  • oh sure, the only thing in common is the blacklist... it worked to me just writing those lines and rebooting... – Wagner Patriota May 1 '14 at 1:28
  • @Wagner Patriota. I just realized what you are talking about. I feel as if you didn't even read my post which is why I was so confused. If you read the OP I had stated that I already added those blacklist commands in my blacklist.conf. – Sandman007 May 1 '14 at 2:00
  • 1
    @WagnerPatriota Its Ok. I am sure I'll find something in the next few days, and I'll post back when I do. Thanks again for your help! – Sandman007 May 1 '14 at 3:36

You may need to edit grub to prevent the kernel from ever loading nouveau at boot. Run the following commands:

cp /etc/default/grub ~/grubbackup
sudo sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT="/GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 /g' /etc/default/grub
sudo update-grub

Reboot.


The file should look like this:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

You can run the following command to verify the contents of the file to be safe before you reboot:

cat /etc/default/grub

If you need to make changes, you can run the following command to edit the file:

sudo nano /etc/default/grub

Press CTR+o to save the file and then press CTRL+x to exit nano.

Also, don't forget to update grub after making changes:

sudo update-grub
  • is it possible for you to post the contents of grub file rather than the sed command(sorry i am not good at sed). Right now that line reads like this:GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with your changes i believe it should be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.blacklist=1". Am I right? When playing with boot and O/S I just want to be extra cautious and careful to save countless hours to recover later. Please clarify. – Ashu May 16 at 23:36
  • @Ashu Additionally, you should also be able to bypass this setting, if the configuration does not work, by booting into recovery or safe mode. – mchid Jun 10 at 20:04
  • 1
    mine worked with putting that extra nouveau.blacklist=1 for the GRUB_CMDLINE_LINUX_DEFAULT. But glad we have some dedicated and committed discussion for nvidia cards to make them work with Ubuntu. – Ashu Jun 11 at 2:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.