1

This community help wiki explains how to make Ubuntu enable numlock upon login:

System Settings > Keyboard Layout > Options > Miscellaneous compatibility options

Check "Default numeric keypad keys"

That worked for me in 12.04 but no longer works in 14.04 because the menu structure has changed. How can I access that setting in 14.04?

0

The same wiki page you linked to says:

""" Enabling NumLock from lightdm configuration

In Ubuntu 14.04 the above methods of running numlockx don't work. It can be run by changing configuration of LightDM display manager. Edit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf file and add the following line at the end:

greeter-setup-script=/usr/bin/numlockx on

This defines running numlockx command when starting the Unity Greeter. (See more info in /usr/share/doc/lightdm/lightdm.conf.gz). """

| improve this answer | |
  • The first solution on that page, titled "Enable Numlock on Login", which I referred to in my question, has nothing to do with numlockx. – Cerran May 1 '14 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.