18

Since upgrading 13.10 to 14.04, I get these annoying messages each time I install, update, upgrade, and so on:

N: Ignoring file 'webupd8team-java-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension 
N: Ignoring file 'bumblebee-stable-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension 
N: Ignoring file 'steam.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntu-x-swat-x-updates-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'xorg-edgers-ppa-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'webupd8team-java-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'bumblebee-stable-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'steam.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ubuntu-x-swat-x-updates-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'xorg-edgers-ppa-raring.list.disable' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

How do I fix the underlying problem told in the message?

edit: Sometimes, I get additional messages appended to the messages above:

W: GPG error: http://www.duinsoft.nl debs Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E18CE6625CB26B26
W: Failed to fetch http://ppa.launchpad.net/person/ppa/ubuntu/dists/karmic/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/person/ppa/ubuntu/dists/karmic/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

And sometimes, I might others, but I cannot find the precise messages anymore.

1
  • Just rename *disable to *disabled and it will be silent.
    – DrBeco
    Jul 4 at 21:01
13

To fix your first problem run this in a terminal:

sudo rm /etc/apt/sources.list.d/*.disable

(An older version of the package management tool left these files when you disabled the PPAs. Removing them is pretty safe)

Your second problem comes from and old Karmic repository. To find out which one run this in a terminal:

cd /etc/apt

grep -rw karmic *

Once you know which repository it comes from it would be easy to disable/remove it.

4
  • 1
    Moving .disable files to another location would be better than deleting. May 1 '14 at 0:27
  • I have the exact same problem as Flair, namely N: Ignoring file 'nginx.list.save.1' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension. But when I enter the command sudo rm /etc/apt/sources.list.d/*.disable, I get the message: rm: cannot remove '/etc/apt/sources.list.d/*.disable': No such file or directory. Anything else I can try?
    – SHW
    Aug 20 '20 at 10:22
  • For all the newbies like me, I found the solution myself. Use command sudo rm /etc/apt/sources.list.d/nginx.list.save.1 to get the specific file removed.
    – SHW
    Aug 20 '20 at 10:42
  • Just rename *disable to *disabled and it will be silent, no need to delete anything.
    – DrBeco
    Jul 4 at 21:01
4

maybe you should try this command:

sudo sh -c "echo 'Dir::Ignore-Files-Silently:: \"(.save|.distupgrade)$\";' > /etc/apt/apt.conf.d/99ignoresave"

 

3
  • This would only mask the issue, maybe suggest a way to remove the files?
    – hazrpg
    Mar 2 '16 at 0:51
  • The dots should probably be escaped. Jul 13 '19 at 15:03
  • would this actually do anything as all the files that the op has listed are suffixed .disabled whereas the answer only has suffixes .save and .distupgrade Oct 18 '19 at 16:50
1

I had a similar issue in Ubuntu MATE 15.04. After

sudo sh -c "echo 'deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main' > /etc/apt/sources.list.d/pgdg.list"

and

wget --quiet -O - http://apt.postgresql.org/pub/repos/apt/ACCC4CF8.asc | sudo apt-key add -

and

sudo apt-get update

I had this message:

N: Ignoring file 'pgdg.listwget' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

I solved this way:

sudo mv /etc/apt/sources.list.d/pgdg.listwget /etc/apt/sources.list.d/pgdg.list
1

[kubuntu 18.04]

I could not work out why the suffixes .distUpgrade and .save were ignored when there did not appear to be anything that explicitly sets this.

Then I discovered apt-config dump | grep -i ignore has entries for these and others:

Dir::Ignore-Files-Silently "";
Dir::Ignore-Files-Silently:: "~$";
Dir::Ignore-Files-Silently:: "\.disabled$";
Dir::Ignore-Files-Silently:: "\.bak$";
Dir::Ignore-Files-Silently:: "\.dpkg-[a-z]+$";
Dir::Ignore-Files-Silently:: "\.ucf-[a-z]+$";
Dir::Ignore-Files-Silently:: "\.save$";
Dir::Ignore-Files-Silently:: "\.orig$";
Dir::Ignore-Files-Silently:: "\.distUpgrade$";

I just renamed my dodgy one to be of of those extensions. (I chose .orig)

0

In my case, it was giving messages for *.save files in /etc/apt/sources.list.d/ directory. I removed them. Now only *.list files exist in there. And those warnings diminished.

Not the answer you're looking for? Browse other questions tagged or ask your own question.