0

This question already has an answer here:

I have some web roots in directories x,y,z, etc. in /var/www/, some of them (not /var/www/) are mounted with options rw,bind,uid=301,gid=301 (301 is uid of user www-data and gid of group www-data). This worked very well in default apache2 of saucy, but no longer with upgraded version in trusty. All permissions of all files and directories under /var/www/ are owned by www-data:www-data. Changing all permissions to 777 (and restarting service) didn't help! I never changed any settings in /etc/... or somewhere.

EDIT: I'm getting 404 error when I request under http://localhost:80/x (error page suggests that apache is running: Apache/2.4.7 (Ubuntu) Server at localhost Port 80). No substring error or fatal in /var/log/apache2/error.log or /var/log/apache2/access.log. netstat -tupln shows that apache2 is running on port 80.

Any ideas?

EDIT 2: Now the pages are also broken with lighttpd (don't have any CSS layout and edit links are not shown in mediawiki (this has been a behavior caused by malious redirection of apache, but can no longer be fixed by requesting the page under different hostnames)). Apache behaves as described before

marked as duplicate by Aditya, karel, Eric Carvalho, Luis Alvarado Jul 24 '14 at 19:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What errors do you get? – Florian Diesch Apr 30 '14 at 23:09
  • I meanwhile switched to lighttpd (which works after enabling configuration, see stackoverflow.com/questions/11537888/…)... – Karl Richter May 1 '14 at 9:29
  • Is there really nothing to see in the error log? Can you check which file Apache is trying to open in the access log? Can you post your configuration? – Louis Matthijssen May 15 '14 at 13:53
0

The default directory of apache2 seems to have changed from /var/www/ to /var/www/html/. So one might (do one of)

  • moving all content there to profit from the advantages of that change[1] (note that this might mess up mess up due to redirection issues)
  • changing DocumentRoot in /etc/apache2/sites-enabled/000-default.conf back to /var/www

[1] see Where to place my local website starting with the 2.4.7 version of apache2? (see comment of @Aditya and existing answer to the question)

Not the answer you're looking for? Browse other questions tagged or ask your own question.