0

I have

emacs.font: Inconsolata-13

in my .Xresources

(And I have said xrdb -merge .Xresources. I have even rebooted the computer.)

When I open Emacs from the command line, it uses Inconsolata. When I open Emacs from the desktop menu, or from file browser ("Open With"), Emacs does not use Inconsolata as its font. (But something that looks like DejaVu Sans Mono).

What is going on?

I have Ubuntu 13.10 and Xubuntu desktop.

2

Right. The Ubuntu menus launch emacs24, not emacs. Have to add to .Xresources:

emacs24.font: Inconsolata-13
1

A safer approach would be to use emacs's own configuration file instead of .Xresources. Add this line to your ~/.emacs:

(set-default-font "Inconsolata")

That will then apply to all emacsen.

  • Thanks. It's just, if I set the font (only) in .emacs, then when I start Emacs, for a blink of an eye the window opens sized to the default font, then the window resizes itself to the font configured in .emacs. I don't like the window jumping quickly from one size to another, so I prefer setting the font in .Xresources so the window appears directly in its correct size. – Sampo Smolander May 1 '14 at 13:42
  • @SampoSmolander lol, classic geek perfectionism :) Fair enough. – terdon May 1 '14 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.