6

I am not able to install LanguageTool extension for LibreOffice. Getting exception when I try to install it.

p.s. Somebody says that the solution is installing openoffice.org-java-common package but Ubuntu 14.04 does not have this package in its repository.

System details:

OS: Ubuntu 14.04 LTS

LibreOffice: 4.2 (4.2.3.3)

LanguageTool: 2.5

Java: Oracle JDK 1.8.0_05

Exception message:

Exception message

8
  1. First of all, the most important:

    sudo apt-get installlibreoffice-java-commonjava-common

  2. Go to LibreOffice Options menu, choose Advanced and be sure Use Java runtime environment is checked and a Java version is selected.

  3. Now install your extension either by double-clicking on it in File Manager or by importing it in LibreOffice Extension Manager dialog.

  • 1
    thanks a lot; now it works for me. The critical package is libreoffice-java-common as you highlighted. – talha06 May 9 '14 at 17:55
  • 2
    I think worth adding: at least with Ubuntu 16.04 and LanguageTool 4.2, you need Java 8, installable e.g. with apt install openjdk-8-jre-headless, and select Java 8 in LibreOffice. Java 7 won't work. – Ivan Ogai Aug 13 '18 at 14:50
1

I had this error with 12.04, turned out java just wasn't enabled in LibreOffice. Might sound silly, but worth a check.

Go to Tools-Options-Advanced. I had the checkbox selected for "Use a java runtime environment", but right under that is "Java runtime environments(JRE) already installed:", and inside that list I hadn't selected anything.

Checked the Oracle 1.7, restarted LibreOffice, installed LanguageTool, all was well.

  • it is already detected and checked for me. – talha06 May 7 '14 at 19:37
0

You need to have OpenJDK Java runtime installed. You can do so from the Ubuntu Software Center. Once done, download the LanguageTool, and choose open with Libreoffice. See image below

enter image description here

If you open writer, you will see it

enter image description here

enter image description here

As per your comments, I have installed Oracle Java, and tried installing LanguageTool, and I got the same error. So I would assume that it will not work with Oracle Java.

  • can't I use with Oracle Java? because I need to use this vendor due to my other works. – talha06 Apr 30 '14 at 15:16
  • I don't see why not. – Mitch Apr 30 '14 at 17:35
  • as I declared in my first post, I have already Oracle Java 8. – talha06 May 1 '14 at 2:48
  • See addition in my answer. – Mitch May 1 '14 at 5:17
0

Using Kubuntu 18.10 and Java 11, the following solution worked for me:

  1. Install the jaxb package: sudo apt install libjaxb-java

  2. Open LibreOffice, and go to Tools -> Options -> Advanced

  3. You should see the Oracle Corporation 11 JRE has been selected.

  4. Select the Oracle Corporation 11 JRE, and click on Class Path.

  5. Add /usr/share/java/jaxb-impl.jar

Restart LibreOffice, and the error should go away. I don't know what else is loaded, and haven't come across any other side effects yes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.