13

I know that many have asked that question before, but I have seen no one ask it for Ubuntu 14.04.

I have a test installation of Ubuntu 14.04 with GNOME 3.10 and I have also installed the Flashback sessions.

What I get is this:

Using either Unity or the Flashback Sessions, (Compiz and Metacity), I can change the change-layout combination to Alt+Shift and it works.

Just a note here using Unity:

If I go to: System Settings-->Keyboard-->Shortcuts-->Typing-->Switch to next source, I can set it to Super+Space but NOT to Alt+Shift.

If I go to: System Settings-->Keyboard-->Text Entry, I can set it to Alt+Shift L.

Now the first time I logged in to the GNOME Shell, the combination worked, but after a while it stopped.

I tried every setting available through the GUIs but none of them worked properly.

Right now I am in a state where the combination works everywhere but the GNOME-Shell.

If, working with GNOME-Shell, I go to: System Settings-->Keyboard-->Shortcuts-->Typing-->Switch to next source, I can set it to Super+Space but NOT to Alt+Shift. Also even if I set to Super+Space it does not work.

If, working with GNOME-Shell, I go to: System Settings-->Keyboard-->Layout Settings, everything is disabled so I have to go to -->Shortcut Settings where I can set it to Super+Space but NOT to Alt+Shift. Also even if I set to Super+Space it does not work. (it is actually the same with the above)

I have also tried to change it through GNOME-Tweak Tool but what it does it is that it actually changes the "Modifiers-only Switch to next Source" found in the above mentioned Keyboard settings, but it still does not do the trick.

In the GNOME-Shell the combination works only to change the layout from EN to GR. In order to change from GR to EN I have to use the mouse and go through the indicator on the top bar. Which by the way does not follow the current layout anyway.

Having faced this problem in Ubuntu 13.10 with GNOME I hoped that it would be fixed in 14.04.

Is there something that I am missing?

My OS Setup is Ubuntu 14.04 64-bit, and GNOME 3.10.4. (Although strangely, when I go to the details on the System Settings it shows that I am using Ubuntu 13.10)

I have set up the system but made no modifications to it whatsoever through command line. I have only used GUI menus, and the only modifications I tried where the ones described above, regarding the change-layout key combination.

  • Looks like this long story not going to the end: bug on launchpad is still open. – dds May 1 '14 at 10:15
  • I have to use 13.04 because I need to switch layout with Super key, and it does not work since 13.10. – dds May 3 '14 at 14:28
  • This works for me on Ubuntu 14.04 LTS: askubuntu.com/a/483718/459225 – kokareff Oct 9 '15 at 6:41
19

You can solve this problem by going to:

System Setting > Keyboard > Shortcuts > Typing > Modifiers-only switch to next source

Click on it and choose "Alt+Shift"

screenshot_settings

This is on GNOME 3.18.

10

To change the shortcut to ALT+SHIFT on Ubuntu 14.04 you must click on language on the bar, and select "text entry settings", and tap on "Switch to previous source using:" or "Switch to next source using:" input and click on "Shift" + "ALT", that's all.

9

I was experiencing some problems with switching the layout and this is how I solved it. Open dconf editor and navigate to desktop->ibus->general->hotkeys and change the values for next-engine and next-engine-in-menu from ['Shift_L+Alt'] to []. Then open Tweak Tool and in the Typing section set the Switching to another layout to alt+shift.

  • Thanks, that works for me in Ubuntu Gnome 15.04. – Mike B. May 2 '15 at 16:49
2

I had the same problem and here is what solved the problem. I had GNOME 14.04 LTS so I followed the path: Tweak Tool -> Typing -> Switch to another layout -> Alt+Shift

Everything solved that way. Tweak tool is already installed in GNOME 14.04 so just search for it!!!!

1

In Ubuntu 17.10, GNOME 3.26.2.1, i got it to work using the GNOME Tweak Tool.

Tweak tool -> Keyboard and Mouse -> Addition Layout Options (button) -> Switching to another layout -> check the Alt+Shift box

0

In my debian wheezy with command $ gnome-shell --version giving output GNOME Shell 3.4.2, I was able to find it here:

System settings / Keyboard / Layout settings / Options... / Key(s) to change layout.

@Gnome devs, you make millions kitties sad by changing the subj in each new version :(

0

if you want set a layout like windows os.
set the below configuration:

img

good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.