61

I'm using Ubuntu 14.04 an my machine and since the last upgrade from 13.10 to 14.04 the date&time is missing in the top panel of Unity. This machine was originally installed with Ubuntu 12.10. I upgraded it from 12.10→13.04, from 13.04→13.10 and last week from 13.10→14.04.

I tried every solution found in this question: Missing date & time from top panel of Unity Desktop. But nothing of all this works :-(

I tried the following things:

  • reinstalling indicator-datetime
  • sudo apt-get remove --purge indicator-datetime and install it again
  • sudo dpkg-reconfigure --frontend noninteractive tzdata
  • sudo killall unity-panel-service

and of course log out/log in again and so on...

Where can I find log files for the indicator or where could help me otherwise with this problem?

Trying to debug:

$ locate indicator-datetime-service
/usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
$ /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
Indicator-Datetime-Message: indicator-datetime exiting; failed/lost bus ownership
7
  • 1
    locate indicator-datetime-service to find where it is installed then run it in terminal. Report if there any error message.
    – user.dz
    Apr 30, 2014 at 18:31
  • @Sneetsher $ locate indicator-datetime-service /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service $ /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service Indicator-Datetime-Message: indicator-datetime exiting; failed/lost bus ownership $ sudo /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service no error output, when running indicator-datetime-service with sudo
    – Bernd
    May 5, 2014 at 8:43
  • failed/lost bus ownership means it was running already.
    – user.dz
    May 5, 2014 at 10:40
  • try reseting its configuration dconf reset -f /com/canonical/indicator/datetime/ . didn't work try pkill -f datetime then /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
    – user.dz
    May 5, 2014 at 10:49
  • 2
    dconf reset -f /com/canonical/indicator/datetime/ worked and it shows the time again. But I think I found a bug and I think I know what causes the issue. Are there any logs for the datetime-indicator to verify my assumption?
    – Bernd
    May 6, 2014 at 6:49

8 Answers 8

137

Try reseting its configuration

dconf reset -f /com/canonical/indicator/datetime/ 

If it didn't show up try kill it, it should restart

pkill -f datetime

For similar cases, better to explain how you may get it:

  1. Check if it is running, if yes then possibly a configuration problem

    $ ps ax | grep -i indicator-datetime
     2863 ?        Ssl    0:00 /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
     4043 pts/0    S+     0:00 grep -i indicator-datetime
    
  2. Check for where is its configuration. Look for /etc/ or dconf in /usr/share/glib-2.0/schemas/. List package files using:

    $ dpkg -L indicator-datetime
    [...]
    /etc/xdg/autostart/indicator-datetime.desktop
    /usr
    /usr/share
    /usr/share/glib-2.0
    /usr/share/glib-2.0/schemas
    /usr/share/glib-2.0/schemas/com.canonical.indicator.datetime.gschema.xml
    [...]
    
  3. Locate its dconf path:

    $ grep path /usr/share/glib-2.0/schemas/com.canonical.indicator.datetime.gschema.xml
        <schema id="com.canonical.indicator.datetime" path="/com/canonical/indicator/datetime/" gettext-domain="indicator-datetime">
    
8
  • 3
    the dconf reset did it for me, thx Jun 3, 2014 at 10:20
  • 1
    I had the same problem after resetting 14.04 and your "dconf reset" did it for me, thanks +1 Nov 12, 2014 at 21:29
  • 14
    dconf didn't help, but pkill did the trick for me.
    – Lambart
    Feb 17, 2015 at 18:09
  • Thanks the dconf reset worked, i didn't even need to kill the datetime process
    – danidee
    Jul 18, 2015 at 23:28
  • 4
    Warning: the dconf trick doesn't just restore the clock. It also resets your clock settings, so if you have customized them... goodbye to your settings. I wish I hadn't tried that -- pkill datetime had already restored the clock to my UI.
    – Lambart
    Sep 25, 2015 at 22:53
20

This worked with me when I faced the same problem:

killall unity-panel-service

without 'sudo' by the way.

2
  • +1 I had the missing-clock-problem a few times already, and this worked reliably as an immediate fix. For the record, indicator-datetime is installed on my machine, so apparently no need to remove/purge it for me.
    – bluenote10
    Nov 29, 2015 at 9:10
  • +1solved Bug Feb 29, 2016 at 5:53
19

I had exactly the same problem, which that some Language Support libraries are missing.

If you go to:

SettingsLanguage Support

The system will automatically update the regional formats and the time and date will be back after you log out and in.

3
  • Tried, but there was no missing language support
    – Bernd
    May 5, 2014 at 8:45
  • 4
    Actually, weird as it sounds, I can confirm this solution. Apparently starting the langauge support panel, some broken libs are indeed (i guess not downloaded but) reenabled. Therefore a +1
    – matv1
    Aug 30, 2014 at 22:42
  • the datetime indicator uses a calendar which requires specific language based format. It seems that it's suffice to take the indicator down :)
    – psukys
    Jan 7, 2016 at 12:03
1

Just kill the indicator-datetime-service process. (This process will get started automatically)

For ex:

$ ps ax | grep -i indicator-datetime
2863 ?        Ssl    0:00 /usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
4043 pts/0    S+     0:00 grep -i indicator-datetime

kill -9 <pid-of-indicator-datetime-service>
kill -9 2863
0

Under System Settings, open Time & Date. Choose the Clock tab to the right of the Time & Date tab. Check Show a clock in the menu bar.

Under In the clock, show, select Weekday, Date and Month, Year or whichever of those you want.

1
  • 2
    The clock tab is greyed out for me - I can't edit the settings there.... Apr 18, 2015 at 9:08
0

Removing the indicator-datetime doesn't remove configuration files and settings under Clock will be grayed out. Doing sudo apt-get purge indicator-datetime; sudo apt-get install indicator-datetime; kill -9 -1; will surely work.

0

i have been trying to fix my time and language icon missing on the panel. i tried many commands but no use but i finally found myself

  • click alt+right mouse on the panel
  • click add to panel
  • double click on indicator applet complete
    your missing icons could be recovered, i had successed by this methode

  • 1
    • please read this Jan 1, 2018 at 15:21
    0

    I am using Ubuntu 16.04 and was facing the same issue. I tried all above-mentioned solution but still facing the same problem. I resolved the problem by deleting file "libxm2.so.2" file from the location "/usr/lib/i386-linux-gnu/libxml2.so.2". First, check if the same file exists at multiple locations on your system. If yes then delete all except from "/usr/lib/x86_64-linux-gnu/libxml2.so.2" Warning: Please backup before deleting this file to avoid any other system issue.

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.