5

I don't know/understand much about this, but I believe mono is an open-source alternative to .NET... But whatever its actual niche is, I really don't know the best way to go about trying to get my windows app to work in wine .. I'm getting a bit fed-up with running a Vista VM just for this one app; I'd much rather see it in wine

I tried installing 'mono for windows' in wine, but my app didn't run, but I really don't have a handle on wine yet, to know if I did something wrong, or it just doesn't work.. I've read reports of success and failure using mono in wine...

So now I'm thinking of just installing MS dotnetfx35.exe in wine, but if it doesn't work, I really won't know if it just requires a simple tweak, or not...

My main question, is: Can MS .NET 3.5 run under wine, and if so, can someone direct me to a how-to... (Simple knowing if it won't work, would save me a lot of wasted time trying to get it working...

(There is no linux/open-source alternative for the app.. )

2
  • 1
    What is the actual windows application you are trying to run? Can you supply a weblink to the supplier? – fossfreedom May 29 '11 at 10:01
  • @fossfreesom.. The site states that a Linux version was available but was not maintained after a particular update to the windows version (a couple of years ago).. It was revived recently, but the .deb doesn't work.. and that's probably because of another update to the windows version) – Peter.O May 29 '11 at 12:22
4

A lot of the more complicated areas of wine can be simplified using winetricks, vineyard and playonlinux. you might find these a helpful starting point.

Also, when it comes to wine: if you don't know if something will work there's normally someone who's had a go before you. you can check the appdb at http://appdb.winehq.org

Apparently the .net 3.5 framework is a tad hit and miss:

http://appdb.winehq.org/objectManager.php?sClass=version&iId=10166

But it appears you can get some functionality using winetricks:

winetricks dotnet30 
wine ./dotnet35setup.exe

Hope this gets you on your way.

1
  • winetricks didn't work for me (but it seems it must work for some, otherwise it wouldn't have made it into winetricks)... thanks. my program is not widley used, and is only relevant to Australia, so it's not surprising that there is no mention of it in appdb either.. oh well, back to the VM with windows as a reluctantly tolerated guest – Peter.O May 29 '11 at 13:36
3

Things like this you can test on wineHQ. If you click the link you will see what has been and who tested and tried to get .net 3.5 to work with wine.

From the page:

What works
Installer runs. 
Download process works.

What does not
Installation stop works.

What was not tested
Unfortunatly Everything.

The comments below that show winetricks can get it to work:

wget http://kegel.com/wine/winetricks
bash winetricks dotnet30

and then

wine ./dotnet35setup.exe

should make it work.

1
  • I tried it. It failed to install, but thanks, it was worth a try... I might try it in a clean 11.04 VM later... I'm using 10.04 and I noticed that my winetricks isn't the latest... – Peter.O May 29 '11 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.