0

When I try to open the themes folder using this command

gksu nautilus /usr/share/themes

this is what the system throws back at me

(nautilus:21515): GLib-GObject-WARNING **: invalid cast from 'GtkMessageDialog' to 'NautilusWindow' ** ERROR:nautilus-window.c:2116:nautilus_window_get_slots: assertion failed: (NAUTILUS_IS_WINDOW (window))

Maybe I'm not typing the right command, please help, I can't access my folders as root...

1

You are not the only one to experience this problem on 14.04.

Here is a bug report: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1309254

And here is a forum thread where people claim to have solved it: http://ubuntuforums.org/showthread.php?t=2216553

Although I can't really see a good solution in that thread - "install samba" seems crazy. The last post in that thread literally says:

The thing that solved it for me, was to install "Samba"

It's probably not samba itself that resolves this but it just so happens to be one of its dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.