I did a fresh install of Ubuntu 14.04 LTS on the harddisk of a Lenovo Y650 Ideapad laptop. The wireless adapter is an Intel PRO/Wireless 5100 AGN [Shiloh].

Initially I could not connect to any wireless networks; however, I could see them. There are no issues when connecting via Ethernet. I was only able to connect to the wireless network by entering this command in the Terminal:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

The speeds are extremely slow and intermittent. When I am able to run a speed test, the ping is good (24 to 26 ms) but the download speeds range from 0.15 to 0.30 Mbps.


eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"PinkRabbit"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: E8:40:F2:CD:18:0B   
          Bit Rate=2 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:254   Missed beacon:0


eth0      Link encap:Ethernet  HWaddr 00:23:5a:d2:70:91  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:15613 (15.6 KB)  TX bytes:15613 (15.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1e:65:3e:0c:48  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::21e:65ff:fe3e:c48/64 Scope:Link
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9032 (9.0 KB)  TX bytes:16851 (16.8 KB)


NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            tg3
  State:             unavailable
  Default:           no
  HW Address:        00:23:5A:D2:70:91

    Carrier Detect:  yes

Wired Properties
    Carrier:         off

- Device: wlan0  [PinkRabbit] --------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        00:1E:65:3E:0C:48

    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *PinkRabbit:     Infra, E8:40:F2:CD:18:0B, Freq 2412 MHz, Rate 54 Mb/s, Strength       92 WPA WPA2

  IPv4 Settings:
    Prefix:          24 (

  • I am facing same issue with my clean install of Ubuntu 14.04 on my new Lenovo L440 laptop. Wifi is not working with driver issue and Ethernet is intermittent. I am clueless on how to proceed! Please let me know if somebody finds some solution – user308609 Jul 24 '14 at 6:09

I don't know how much relevant this may be, still an Ubuntu newbie, but I had similar problems with my Ralink 5362 card.

The only thing it seemed to work was the following:

There is a bug in the Debian Avahi daemon in Ubuntu. And to resolve this you need to edit the following file /etc/nsswitch.conf as follows.

Type the following in the command line

sudo -H gedit  /etc/nsswitch.conf

This will open the nsswitch.conf file in the text editor. Then simply change the following line

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

to the below line and save the file.

hosts:          files dns

Reset your internet connection or probably restart your system and your wireless connection should be back on top speed. This worked for me at least.

  • 2
    Hey, can you explain what this does? Asking out of curiosity, as this solved the problem for me too. – kapv89 May 6 '16 at 16:59
  • 1
    Works on Dell Latitude e7450 with Intel wireless card 7265, thanks for this comment. I also would like more explanation of code above. – abibock_un May 11 '17 at 12:51

I actually have this problem too, so I look forward to any permanent solution, but one temporary one would be:

sudo iwconfig wlan0 rate 54M

where 54M is your actual wireless capability.

  • Hey, I tried this. It gave me error: Error for wireless request "Set Bit Rate" (8B20) : SET failed on device wlan0 ; Operation not supported. Any other quick solution? – Ravi Dhoriya ツ Jan 17 '15 at 14:12
  • Ok, so far this has been the only solution for the Lenovo T400 Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection and worked like a charm with the exact syntax provided in the answer. Nevertheless, this problem seems to be happening just on the i3WM, so I added the @reboot iwconfig wlan0 rate 54M to my crontab by using sudo crontab -e in order to make it automatically set this rate from every reboot/start. Just for information. Thank you very much. – Geppettvs D'Constanzo Jan 20 '15 at 0:13
  • What do you mean by "i3WM"? @GeppettvsD'Constanzo My same wireless adapter on T400 can lost connection and become disabled after a while (some hours or a day) after booting my Ubuntu 14.04. May this method (for solving low speed problem) help? (At the same time, my wired adapter and an external wireless adapter sometimes may also become disabled.) – Tim Apr 13 '15 at 18:15
  • Hello @Tim, first of all: "i3WM" is a Window Manager called "i3". More information in this link: i3wm.org, for what is about your connection problem. It should provide some help, how much? We can't say for sure. But I can say you that, after updating the whole system a couple of times the disconnection problems are gone from my equipment. You should try updating and -why not?- doing this solution. It won't harm your computer. The most you will need to do this on every boot or -as I did- use the crontab in order to do it for you. Good luck! – Geppettvs D'Constanzo Apr 14 '15 at 14:15
  • You can do sudo lshw -C network and get the logical name of you device, then do the command sudo iwconfig wlan0 rate 54M with whatever your logical device name is (mine was wlo1). askubuntu.com/questions/333424/… – wordsforthewise Aug 2 '16 at 10:33

I've noticed the same issue with my laptop (Intel Wireless 7260 / Lenovo W540). Every few days networking slows to a crawl (includes traffic over all protocols: http, ssh, ftp, etc). I believe I've also experienced the same behavior over eth0, but can't remember.

The workaround for me is to restart network-manager -- that seems to clear out any issues.

jmiranda@jmiranda-ThinkPad-W540:~$ sudo service network-manager restart


jmiranda@jmiranda-ThinkPad-W540:~$ sudo lshw -C network
       description: Ethernet interface
       product: Ethernet Connection I217-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: 3c:97:0e:ea:1b:a4
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 memory:b2a00000-b2a1ffff memory:b2a3f000-b2a3ffff ioport:5080(size=32)
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 6b
       serial: 7c:7a:91:06:7b:e2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-29-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:45 memory:b2800000-b2801fff
  • didn't improve my speeds, same laptop too – bobbyrne01 Mar 18 '15 at 18:24

I can suggest you to install the Kernel 3.13.0-37_3.13.0-37.64+iwlltr0001 from: http://people.canonical.com/~sforshee/iwl-ltr/trusty/

and the Intel firmware iwlwifi-3160-9-ucode.

After that, I typed in a terminal:

$echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
$echo "options iwlwifi bt_coex_active=Y swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
$sudo reboot

  1. Open "Additional Drivers"
  2. Go to "Other Software" Tab, check all the boxes
  3. Update the driver
  • 1
    It will help to explain what the proposed solution is supposed to do. Without adding any detail this sounds like a longshot with low change of hitting the target. – Requist Dec 16 '14 at 19:53
  • Edit your answer and improve it and I will reverse the negative reputation points you've got now. Alternatively, delete your answer and the negative reputation points will be reversed too. – Fabby Dec 16 '14 at 21:51
  • This answer lacks of explanations but I tried it and it worked. On my pc the "other software" tab had the Canonical checkboxes uncheched. I think my network adapter's drivers weren't installed before... But I'm an Ubuntu newbie so... – andrea.rinaldi Jan 3 '15 at 12:24
  • I think that's what finally helped me after days of struggle. – lakesare Jul 8 '16 at 17:03

Try disabling IPv6: Go to edit network connections, select your connection, go to IPv6 tab, change it to ignore.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.