8

I have an HP Elitebook 850 G1, and installed a fresh copy of Ubuntu 14.04, however Ubuntu is not detecting the built-in Webcam. Is there any ways to fix this, and why this is happening?

output of the lsusb

Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0424:5534 Standard Microsystems Corp.
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 138a:003f Validity Sensors, Inc.
Bus 002 Device 004: ID 8087:07dc Intel Corp.
Bus 002 Device 002: ID 0424:2134 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
3

UPDATE: Actually, I just found that you need to manually add your user to the audio and video groups. The easiest way is to launch the "users and groups" app and go to manage groups

Original answer:There seems to be an issue with the permissions on /dev/video*.

They are owned by root with no read/write permissions for regular users. My quick-and-dirty hack was a simple:

sudo chmod 777 /dev/video*
  • 6
    My user was already added to both be "video" and "audio" groups. When I run the chmod command, I receive: chmod: cannot access ‘/dev/video*’: No such file or directory – Aang May 8 '14 at 22:32
  • 2
    I've added myself to the "audio" and "video" groups via the Users and Groups tool - still no luck using my integrated webcam :-( It still shows up as "No device found" in Cheese, and "Could not connect to video device (/dev/video0)." in Camorama. – Aang Sep 5 '14 at 23:12
  • 3
    Nice, so anyone could access your webcam! Cheers! for anyone that doesn't want the entire world to view them on their own webcam do sudo chmod 775 /dev/video* – Edward Sep 22 '15 at 13:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.