I'm running 13.10 (all up-to-date) on a Lenovo laptop with a Griffin iMic USB audio device. Though I occasionally have to use the Pulse Audio volume control tool to re-select the iMic, it works consistently from everything on the system except Chrome, which basically has no audio at all.

With most applications that want to use the audio stuff, you see something in the first tab of pavucontrol. Not Chrome; there's just nothing.

Some ancient forum posts here and there suggested symlinking the Firefox "plugins" directory over to Chrome's installation directory, which seems pretty goofy and which doesn't work now anyway.

Chrome version is 34.0.1847.132.

Is there some trick to making Chrome work with a USB audio device? (As far as I can tell it doesn't work with built-in audio either ...)

edit — Still not working, now on 14.04 and Chrome 37.0.2062.120

More info:

Chrome's been reinstalled more than once, with no effect. I've also tried the beta (currently Chrome 38.0.2125.77 beta). The PulseAudio manager tool, in its list of clients, shows Firefox and various other things, and also "Chrome input" but no "Chrome output".

Chromium behaves exactly the same way.

edit — now on an (old and tired) 15.04 installation. Chrome (Version 49.0.2623.112 (64-bit)) still does not work, though on full moon nights or something else random it'll send sound through the built-in analog audio on the laptop. However, Chromium (Version 48.0.2564.82 Ubuntu 15.04 (64-bit)) does work now, and it works through the USB audio device. I don't know of any particular thing I've done lately to make that true, but

  • 2
    Is Chrome muted in the sound settings?
    – s3lph
    Sep 26, 2014 at 20:48
  • @the_Seppi no, it isn't, as far as I know. I'm running xfce4 as my desktop; I don't even know where such a settings panel (or config file) might be.
    – Pointy
    Sep 26, 2014 at 20:55
  • Execute (and install, if not found) xfce4-mixer from a terminal.
    – s3lph
    Sep 26, 2014 at 20:57
  • @the_Seppi well that gives me volume control etc, but it has no effect on Chrome. (Thanks for the suggestion however.)
    – Pointy
    Sep 26, 2014 at 21:01
  • 1
    Does it only apply to Flash or also everything else? w3schools.com/html/html5_video.asp Watch this video. If you hear anything, it's a Flash problem. If not, it's really Chrome-related.
    – s3lph
    Sep 26, 2014 at 21:08

10 Answers 10


I had the same problem. It ended up being that my system was trying to put Chrome's sound through the HDMI even though the HDMI chord was not plugged in at the time. Presumably, this could happen with any audio output device. The sound settings Ubuntu offers didn't show this nor let me change it for the individual application, but pavucontrol did.

To install pavucontrol from the Terminal:

sudo apt-get install pavucontrol

To open pavucontrol from the Terminal:


Select the "Playback" menu and make sure that you have it set to Show Applications. Now, start playing something from Google Chrome. It will show up there, and it will show what output device is being used for Google Chrome. Make sure it is set to the output device you are trying to use.

  • 3
    Thank you so much for this! I suspected this to be the issue after sound from half my apps disappeared after I had connected then disconnected the laptop to a screen via HDMI, but the default Unity control center doesn't show which outlet the sound was going out from on a per application basis.
    – Yi Jiang
    Mar 1, 2017 at 6:50
  • Repeat these steps for microphone input if you're also having issues with that. A good site to test on is onlinemictest.com
    – Zaz
    Dec 21, 2017 at 0:40
  • Perfect, this way I didn't have to kill pulseaudio or remove pulseaudio configs. pavucontrol still seems to work fine under 18 LTS as well.
    – jerome
    Sep 1, 2018 at 10:22
  • I would just like to say thank you so much because pavucontrol worked for me :D It seems the sound controls failed to default back to "Built-in Audio" after using HDMI.
    – Robin Hood
    Oct 16, 2018 at 19:11
  • 6
    Thanks a lot, not all heroes wear capes nowadays
    – Tri Nguyen
    May 24, 2019 at 6:59

This work for me (Ubuntu 14.04):

killall pulseaudio
rm -r ~/.config/pulse/*
rm -r ~/.pulse*

And reboot.

These commands will stop pulseaudio and remove its current configuration, to start with the defaults again.

  • Thanks for your suggestion. I'll give it a try at some point.
    – Pointy
    Sep 2, 2015 at 13:29
  • Worked for me too on Ubuntu 12.04. Had to restart Chrome after the operation.
    – Tony
    Sep 3, 2015 at 5:41
  • Worked for me perfectly.
    – axel22
    Mar 22, 2016 at 9:55
  • 11
    Could you please describe in your answer what these commands actually do? Apr 3, 2016 at 8:57
  • 2
    Worked for me on Ubuntu 18.04. May 16, 2018 at 0:15

Before wiping out the entire Chrome configuration directory, try this: switch to another audio output device and then switch back to the original one. If you have only one audio device, connect an external one (like HDMI or USB audio) and then perform the above trick.

Update The following seems to prevent the problem from reappearing in the future:

  • Edit /etc/pulse/default.pa, find the line that starts with load-module module-stream-restore and add restore_device=false at the end so that the line looks like this:

    load-module module-stream-restore restore_device=false

  • Do killall pulseaudio

  • 3
    Switching to a different audio output and back solved it for me. Thanks! Oct 30, 2018 at 17:18
  • Switching also worked for me, but I also did the configuration removal of ~/.config/pulse as described above, however, that didn't work until I switched the audio input to something else and back. I did not change /etc/pulse/default.pa Jul 4, 2020 at 13:51
  • I had the same issue as OP on Ubuntu 22.04. I found the included Pulse Audio Volume Control gui's Output Devices tab had an entry for Chrome with output going into HDMI (even though my overall system output was set to output to headphones). Unfortunately, the setting would re-appear on the next reboot. The solution above (the part after the Update) stopped it from re-occurring on re-boot. May 29, 2023 at 22:04

I had a similar problem. My laptop had two sound cards, one for built-in audio from the laptop speakers, the other to come through the hdmi output. When I was playing music or something that used the browsers sound, it was channeling the sound through the hdmi channel. From the kmix sound manager, I could see that chrome was listed in the playback streams but if you right clicked on the chrome icon and select move, there was an option to change the audio output for the stream. I made sure it wasn't hdmi, since I wanted the sound to come from my speakers or headphones.


None of the above worked form, been without sound in chrome for a week. Then I started SMplayer, no sound also, Options>Pregerences>Audio switched from pulseaudio to alsa.

Next time I started chrome sound works.

  • Thanks. Your solution worked for me. I'm running Linux 5.1.19_1 (Void Linux)
    – dgo.a
    Jul 24, 2019 at 1:05

Chrome comes with an integrated flash player and it does not always work well.

If you have sound with Firefox on websites like youtube or deezer, maybe you already have a Flash player on your system: the package "flashplugin-installer".

If not:

sudo apt-get install flashplugin-installer

Then, you can set which Flash player you want in Chrome's plugins setting:

  • open a new tab, type chrome://plugins instead of a URL
  • click on details on the right,
  • select Adobe Flash Player
  • you will see two different "sub" plugins
  • disable the current one and enable the other one
  • restart Chrome

You can also find a short video about how to do it with on Chrome for Windows, this is the same way in Ubuntu:

  • Thanks, but as far as I know modern versions of Chrome don't support the old Netscape plugin API any more. I have flashplugin-installer installed on my system, but with Chrome the only Flash option available is PepperFlash.
    – Pointy
    Sep 29, 2014 at 19:35
  • You are right, since Ubuntu 14.04, Chrome and Chromium can not use anymore the Netscape plugin API. Maybe you should follow this tutorial ? itsfoss.com/fix-flash-player-issue-chromium-in-ubuntu-14-04. However, my answer should be good for Ubuntu 12.04
    – ttoine
    Oct 3, 2014 at 11:39
  • I've got Pepper Flash installed and updated already, thanks.
    – Pointy
    Oct 3, 2014 at 12:41
  • you tell you re-installed Chrome many times. But did you delete the .config/google-chrome folder in your /home ?
    – ttoine
    Oct 3, 2014 at 12:46
  • Yes, I have tried Chrome with freshly-made user accounts and after removing my own .config directory. This problem has been going on for almost a year, so I've had plenty of time to experiment :)
    – Pointy
    Oct 3, 2014 at 12:52

Check you are running the right architecture of Chrome.

I had i386 Chrome installed on a 64 bit system and had this issue. When I uninstalled and installed the 64bit version, audio worked fine.


I had the same problem you may not notice any issue immediately after i install chrome-remote-desktop problem occurs after i reboot my pc. so following worked for me. I am using : Ubuntu 18.04 LTS

  1. sudo apt-get autoremove chrome-remote-desktop
  2. killall pulseaudio rm -r ~/.config/pulse/* rm -r ~/.pulse*

copy and past each line in the terminal. Hope it helps


A simple reinstall of Chrome worked for me on Ubuntu 14.04.

sudo apt-get install google-chrome-stable --reinstall


Yesterday you might have simply right-clicked a tab, and selected "Mute site", and forgot about it. Now e.g., none of YouTube's videos have sound!

Perhaps you got a phone call while watching a video, just before leaving work.

So simply right click the tab, and click "Unmute site"!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .