2

I am running Xubuntu 14.04 64 bit. I installed Steam about 2 months ago, without using the 32 bit libs or anything. When it last prompted me for updates (yesterday), I didn't to update it and I haven't been able to start it since then.

Output when run from terminal:

$ steam
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1393366296_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140504021210_1.dmp
/home/elie/.local/share/Steam/steam.sh: line 755: 18302 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
mv: cannot stat ‘/home/elie/.steam/registry.vdf’: No such file or directory
Installing bootstrap /home/elie/.local/share/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME has been set by the user to: /home/elie/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(1393366296_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140504021213_1.dmp
/home/elie/.local/share/Steam/steam.sh: line 755: 18432 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-548166d2-e868-46b4-ac37-b548b2140503
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-132434a3-69e3-4dff-96fe-a2be32140503

I tried installing 32 bit libs, updating my system, upgrading, reinstalling, deleting appcache.

What can I do?

  • I can mostly solve this by launching with STEAM_RUNTIME=1 steam about 5 times. Sometimes I click the launcher 10 times in a row instead. I've heard mention that you can reinstall graphic drivers, but I haven't tried that. – Sparhawk May 4 '14 at 0:04
  • @Lynob, Please do not post an answer as an edit. I have moved it to a community wiki answer. For you to get the reputation, you should post as an answer and flag mine for deletion. – fosslinux May 2 '18 at 22:38
2
+50

Two weeks ago there was a post on ubuntuforums.org about an extremly similar issue. The outputs you had was identical in all ways possible, only thing was he didn't have the issue during update, but rather installation.

According to this post there may be a difference between installing Steam from a PPA, Software Center, Synaptic or official DEB package. Installing it through all those sources you can be successful, according to the post.

Another very common issue is that the graphics drivers are "incorrect". Speaking from own experience, changing drivers and reinstalling can solve the issue. By changing I mean switch from Open Sourced drivers to Closed and vise versa.

When reinstalling Steam, if you don't want to delete your game data you should be able to follow ChrisR's suggestion of saving the SteamApps folder and then replace the new contents with your old save.

P.S. I apologize as this maybe should have been posted like a comment. The thing is, I don't have enough rep for that so I hope you'll except my vague attempt to an answer :)

  • seems that changing the graphic drivers, going back to xorg solved this issue (weirdest solution ever) and I shall accept your answer – Lynob May 4 '14 at 11:15
  • @Fischer What exactly do you mean by "going back to xorg"? – Sparhawk May 4 '14 at 11:18
  • @Sparhawk I meant using xorg instead of fglrx which I usually use – Lynob May 4 '14 at 11:21
  • @Fischer I'm so confused. Doesn't fglrx run in X? – Sparhawk May 4 '14 at 11:29
  • @Sparhawk I don't know what happened, I had to use xorg, only then steam started, then it updated then I reused fglrx and steam worked – Lynob May 4 '14 at 13:14
1

This is a Community Wiki answer of the OP's answer which was in the question.


I had to change my display server to Xorg. When I did, Steam opened and downloaded the update.

I went back to fglrx and steam is now working.

  • I have edited the OP's answer so it is more clear. The original answer should be available in the revision history. – fosslinux May 2 '18 at 22:41
0

When I had this problem in the past (refusing to upgrade steam), I had to completely reinstall steam. You can save your currently installed Steam games by going into:

[name of steam folder]/SteamApps

and saving everything inside that folder. Once you reinstall steam, just copy the contents back into the same directory (e.g. Steam/SteamApps). Then, restart Steam and you should be good to go.

  • but I did try to reinstall it, many times, didn't work, using apt-get, using synaptic and using the latest deb from their site, i did remove it and reinstall it, I just didn't remove the games folder, apt-get doesn't do that by default, didn't solve it – Lynob May 3 '14 at 23:50
  • @Fischer Did you also delete the Steam files in your home folder? – Sparhawk May 4 '14 at 5:33
  • @Sparhawk didnt have to, going back to xorg solved the problem mysteriously – Lynob May 4 '14 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.