So I upgraded from Ubuntu 12.04 to 14.04 and now I see Floppy in my Home Folder tree how do I remove it?

what I did since Ubuntu 12.04 is:

  • Edit /etc/fstab to remove reference to floppy.

  • Edit /etc/modprobe.d/blacklist and add this line at the end: blacklist floppy

  • Run: sudo update-initramfs -u

  • Run: sudo update-grub

  • Restarted the system.

I checked /etc/modprobe.d/blacklist it contains blacklist floppy like it was before the upgrade but now I can see floppy in my Home Folder tree. Is there something else I need to change in 14.04?

1 Answer 1


Problem solved! Found the solution on Ubuntu 14.04 in terminal run:

  1. echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf

  2. sudo rmmod floppy

  3. sudo update-initramfs -u

works right away.

  • Doesn't work on my 14.04 system.... ~$ sudo rmmod floppy rmmod: ERROR: Module floppy is in use
    – Jebeld17
    May 30, 2014 at 17:23
  • @Jebeld17 did you unmount it and blacklist it first? This workaround works on my system right away. And this answer solved my problem, if you experience issues with something else you should consider creating your own question.
    – JoKeR
    May 30, 2014 at 17:32
  • I had this issue with Ubuntu 14.04 on a VMware workstation 10. This was the only one solution i've found that solve the problem.
    – ame-h
    Jan 13, 2016 at 4:55
  • Seems to have worked on my 16.04 server system on VMWare ESXi host.
    – flickerfly
    Apr 29, 2016 at 20:57
  • to unmount floppy - sudo umount /dev/fd0
    – Alexey
    Oct 9, 2016 at 9:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .