Xubuntu 14.04 64 bit. I used VLC media player 2.1.2 Rincewind (revision 2.1.2-0-ga4c4876). I also tried the daily builds, 2.2.0.

VLC crashes. I opened a bug report at VLC's bug tracker, they asked for backtrace

#0  strlen () at ../sysdeps/x86_64/strlen.S:106
#1  0x00007fffe884d7a0 in mkdirhier () from /usr/lib/libtar.so.0
#2  0x00007fffe884c19d in tar_extract_dir () from /usr/lib/libtar.so.0
#3  0x00007fffe884c3fb in tar_extract_file () from /usr/lib/libtar.so.0
#4  0x00007fffe884dc32 in tar_extract_all () from /usr/lib/libtar.so.0
#5  0x00007fffe8ab5bfb in ?? ()
   from /usr/lib/vlc/plugins/gui/libskins2_plugin.so
#6  0x00007fffe8ab6c48 in ?? ()
   from /usr/lib/vlc/plugins/gui/libskins2_plugin.so
#7  0x00007fffe8ab73cb in ?? ()
   from /usr/lib/vlc/plugins/gui/libskins2_plugin.so
#8  0x00007fffe8ab2854 in ?? ()
   from /usr/lib/vlc/plugins/gui/libskins2_plugin.so
#9  0x00007ffff79a8182 in start_thread (arg=0x7fffeb2d7700)
    at pthread_create.c:312
#10 0x00007ffff74d130d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

I also gave them this file, they closed my ticket and labelled it incomplete.

I just want to know if it's a bug or not. If it's a bug, I'll reopen the ticket, I will delete this question. If it's not a bug, then how to fix it? Everything was working fine on 13.10.


I'm not interested in fixing this bug anymore. Mplayer with Umplayer offer me many more features than VLC. I'll accept the only answer and vote it up just to close this post, although I haven't tried it. I'll leave that question for its value, maybe someone else has the same problem, and maybe he'll find a solution by reading this post.

  • Start vlc using gdb as follows: $ gdb vlc At the gdb prompt press r to run the program. (gdb) r When vlc crashes, errors will show up on terminal. Provide the same info to the developers. It might help them. – Ish Sookun May 6 '14 at 15:02
  • Crashes are usually the result of bugs. You can get debug symbols for Ubuntu's vlc in vlc-dbg. Run it in gdb as already suggested. – bain May 6 '14 at 16:00
  • @IshSookun I'm not interested in fixing this bug anymore – Lynob May 7 '14 at 9:43
  • @bain I'm not interested in fixing this bug anymore – Lynob May 7 '14 at 9:44
  • The question has already been answered by @rintaro – bain May 7 '14 at 9:46

This is a bug in libtar 1.2.20-3 as patched by Debian and Ubuntu. The original libtar 1.2.20 doesn't show this bug. Providing a target directory that is different from the current directory results in SIGSEGV. This bug can be easily reproduced with the libtar example program : libtar -C /tmp/target_dir -x -z default.vlt

  • I'm not interested in fixing this bug anymore – Lynob May 7 '14 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.