58

There is a strange noise from my headphones on Lenovo T440. The sound is like when you tune your radio, but you get a wrong frequency and you hear unpleasant noise. The noise starts when Ubuntu 14.04 boots up and ends after a shutdown. It is coming out only through my headphones, there is no noise through the speakers.

The strange thing is that the noise disappears when any sound is played or if I enter sound preferences. But when a sound is stopped, it appears again after 10 seconds or less. Also, the noise goes way down (or maybe even disappears) if I put in my laptop charger and stop the music.

No matter how I change my volume level, the noise level is the same. It seems like the output is not disabled after sound stops.

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
4
  • im on the lenovo t440s and this issue recently occured with my setup on 14.04 as well. as unrelated as it seems, my hunch is that it happened after I altered some /etc/x11/ mouse related settings and then restarted lightdm. was never an issue in the past and now its pervasive. Dec 27, 2014 at 18:53
  • The problem was gone after I changed the beep channel in alsamixer from 0 to something else and back to 0
    – EECOLOR
    Nov 2, 2015 at 1:01
  • 2
    Possible duplicate of The bad old Noise issue in the headphones on Ubuntu 16.04 LTS Feb 5, 2017 at 4:36
  • 1
    reversing direction (voting to leave this open) as this post has more answers views and votes
    – Zanna
    Feb 7, 2017 at 6:00

16 Answers 16

40

Got the same problem on Dell XPS15 (9550, 2015 model in Xenial). Solved it in alsamixer and muting the loopback channel.

$ alsamixer

Navigating to loopback (all the way to the right, with key) and setting it to Disabled using the key.

  • No reboot needed;
  • No root needed;
  • Is permanent as far as I noticed.
12
  • This solution worked on my Dell Precision 5510.
    – dmiller309
    Aug 17, 2016 at 18:49
  • This worked on my Dell Precision 5510 as well. Thank you!
    – L42
    Aug 25, 2016 at 8:56
  • 1
    With this method, you can also keep the powersave on, and thus save battery.
    – JonasCz
    Sep 26, 2016 at 10:09
  • 4
    My looback is already set as Disabled by default ): Sep 27, 2018 at 20:06
  • 4
    I changed 'Headphone Mic Boost' to 10 (one up) and somehow solved. Here I also found someone suggesting it. (Dell XPS 13 9360)
    – Jo'
    Oct 6, 2019 at 9:21
38

It's possibly your audio interface going into power save.

If following commands clear the issue until you reboot or change the power supply it has got something to do with power save:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
10
  • 3
    Thanks! This one works on other distros ;-) I ended up having something like "options snd_hda_intel power_save=0 power_save_controller=0" in my modprobe.conf... Aug 18, 2016 at 6:46
  • 1
    Worked perfectly for me, Xenial on Dell Inspiron 14 7000
    – Ren
    Jun 6, 2017 at 0:27
  • Continues to work with 18.04 LTS (bionic). Aug 23, 2018 at 5:27
  • 4
    It still works on Ubuntu 20.04. Thank you.
    – Edip Ahmet
    Aug 28, 2020 at 7:18
  • 3
    but the issue is that when i restart the computer the problem again come and i have to again write the code Apr 10, 2021 at 7:40
16

I had the same problem on Dell Inspiron 3542 running Ubuntu 14.04.2

The problems appears to be in the audio powersave feature.

The noise stops when I open the sound settings, or when I play audio/video. The noise starts again when I stop playing audio/video and close sound settings.

This solution worked for me: Edit the file

$ sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

change the line

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

to

INTEL_AUDIO_POWERSAVE=false

Reboot.

I faced no further noise after this.

6
  • Worked perfectly for me, Xenial on Dell XPS 13 9350 May 17, 2016 at 23:34
  • 2
    any ideas why power save is causing these strange noises? Isn't power save a good thing. I'm just curious! Jul 30, 2016 at 13:49
  • sudo aplay -l gives me a similar output. I am using Dell Inspiron 15 3542. I don't have "intel-audio-powersave" file. Can I create one? Jan 25, 2017 at 2:22
  • Possibly you need to select correct sound card by using F6 first
    – Alex0007
    Jun 5, 2017 at 17:42
  • You are soooo awesome!!! Worked on my Macbook 2006 Late running only Ubuntu 16.04 LTS :)
    – yanike
    Nov 14, 2017 at 5:38
6

I had the same issue. I believe it is the noise that your microphone picks up.

Go into Sound Settings, under the Input tab, check Mute box near Settings for <microphone_name> Microphone (Not the Mute checkbox at the top).

enter image description here

That should do the trick.

5
  • Following your instruction, my headphone is mute. Feb 27, 2015 at 2:17
  • For me on a Dell M3800, that had no effect.
    – Garrett
    Mar 3, 2015 at 3:25
  • the microphone does not typically play over the speakers unless you run pactl load-module module-loopback latency_msec=1
    – mchid
    May 21, 2015 at 0:55
  • This worked for me. Muting the microphone removed all the noise. Thank you. Dec 23, 2015 at 20:54
  • This worked. Can someone explain why this works?? Jun 25, 2016 at 18:32
6

I had the exact the same problem and none of above method worked for me.

My laptop is ASUS ROG-G501JW and the sound card is Realtek.

I found the solution in this thread: White and hissing noise in headphones, not present in Windows.

Setting this line in /etc/modprobe.d/alsa-base.conf fixed all of my problems:

options snd-hda-intel model=dell-headset-multi
1
  • 1
    Confirmed on ASUS ROG-G501VW
    – rob
    Apr 2, 2020 at 8:58
3

Do you have tlp activated?

If so edit /etc/default/tlp and set the power save option values to 0

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

this did the trick for me

3
  • On my Dell M3800, I tried setting SOUND_POWER_SAVE=0, but it didn't help...
    – Garrett
    Mar 3, 2015 at 3:25
  • For me, setting these values to 1 helped. Feb 8, 2020 at 15:35
  • Thanks. I had a similar problem on 19.10, and this is what fixed it for me. In my case, the hum was present when I plugged my stereo deck into the laptop, but not when I plugged in headphones. May 31, 2020 at 20:59
1

I just found this thread because I had the fuzzy earphones as well, but because of a different reason.

I have a USB fan plugged into my laptop and whilst it's turned on, I hear the fuzz on my earphones, so check if there are any devices on your USB ports causing the interference on your sound before testing the software fixes.

1
  • Why, why does this happen? As I read your answer, I noticed I didn't have my mouse plugged in before when I was listening to music and I did now. Disconnected it, and it works!
    – RedClover
    Feb 4, 2020 at 21:05
0

I've had this problem on Dell 3542 with Ubuntu 16.04 GNOME and it started happening after I installed TLP for power saving. So after I saw here that the problem is related to power saving I simply uninstalled TLP and the problem was gone.

0

I had this problem on Asus X200ca with ElementaryOS Loki (Ubuntu 16.04) and other linux distro that I had used. I fixed issue with

  • run alsamixer (not in sudo mode)
  • Navigate to Auto-mute Mode (using right arrow)
  • Change it to enable (using up arrow)

Now I don't have the problem again.

0

I found an unusual cause for my excessive background noise... my Civilization 5 (run via Steam) was not exiting properly. The background noise I was hearing was from the game. I used "htop" to find and kill all Civilization processes and sure enough, the noise decreased every time I killed off a process from the game.

So not an Ubuntu nor audio problem; it was in fact one particular app (that never exits right anyway).

0

I had the same problem on my Kubuntu 18.04 and I solved by following this answer, changing "Front Mic Boost" value from "dB gain 0,00, 0,00" to "dB gain 10,00, 10,00"

0

I had dell too, the same problem. No one cli-command no help me(.
I try tuning alsamixer. option Headphone M see screenshot

$ > alsamixer

enter image description here

0

Solution

If this is due to the persistent battery mode of TLP then the solution is easy.

First, check if this is the case. Run sudo tlp-stat -s, if this shows Mode = battery (persistent), then that's the cause of it.

The Fix is simple. Infact it was pointed out by @Foxtour in one of the answers.

  1. Create a new file /etc/tlp.d/95-YOUR-NAME.conf and add the following content

    TLP_DEFAULT_MODE=AC
    TLP_PERSISTENT_DEFAULT=0
    
  2. Restart tlp

    sudo service tlp restart
    

Background

I am using ubuntu 20.04. I have never configured TLP and the Dell laptop has a freshly installed Ubuntu. This happened due to these 2 config options added in /etc/tlp.d/50-estar-default.conf.

TLP_DEFAULT_MODE=BAT
TLP_PERSISTENT_DEFAULT=1

This means, the default mode is battery and this will be persistent all that time. It doesn't change even if you are on AC.

This configuration option was added by package oem-fix-misc-cnl-tlp-estar-conf. The apt-cache show oem-fix-misc-cnl-tlp-estar-conf shows this description

Description: customized configuration for tlp.
 This package carrys agressive policy to pass energy-star, and also some blacklist for problematic devices.

Now you know why this happened

0

I don't know if you still have this problem, but for me the solution was to lower the volume of the headset from the physical buttons on it.

If your headset has physical volume down buttons, turn the volume down using them. I guess the volume was so high it was transmitting the Bluetooth signals into noise.

0

For Asus G551VW the above steps did not work for me. In this article you will find correct steps to install alsa & give it correct model name to use while communicating with the sound chip. For G551VW it was alc668-headset.

0

In /etc/pulse/default.pa and /etc/pulse/system.pa, comment the following line:

load-module module-suspend-on-idle

Or try to create the file ~/.config/pulse/default.pa with the lines:

.include /etc/pulse/default.pa
.nofail
unload-module module-suspend-on-idle
.fail

Sources: Static noise when NO audio playing, https://wiki.archlinux.org/title/PulseAudio/Troubleshooting#Pops_when_starting_and_stopping_playback

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.