16

I am using a Microsoft Natural® Ergonomic Keyboard 4000 on my Ubuntu 14.04 x64 and since I upgraded from Ubuntu 13.10 I noticed that the Calculator application does not get focus when started from the keyboard shortcut. It gets started like the last (NOT previous) application in the stack.

It gets focus when opened from dash.

I don't know what configuration output to provide. Any suggestions?

14

What you have discovered seems to be a bug related to some applications launched from (unity)*-settings-daemon. The bug is reported here.

However, it exist multiple easy workarounds to this annoying issue;

The one I will suggest, is to define your own keyboard shortcut, and reassign the calculator button.

keyboard shortcut


Another solution is to:

Use eg. CompizConfig Setting Manager and set the Focus Prevention Level option to off. The option is found under General Options on the tab named Focus & Raise Behaviour.

  • today's upgrade seems to have fixed it. – Alex Burdusel Apr 30 '14 at 18:38
  • Hi, the proposed answer is not what I expected. I want to have focus prevention and have my calculator app to gain focus when launched from keyboard. Is that possible? – razor7 May 8 '14 at 22:39
  • 1
    Well, I my particular case, If I create a custom shortcut using the calculator button on my keyboard, the calculator app doesn't show at all... – razor7 May 9 '14 at 2:22
  • 2
    The alternative solution (using CompizConfig) resolved the problem for me, as by adding a custom shortcut, the application did open on top of other apps, but didn't receive focus and thus still didn't receive immediate input. – Paul Lammertsma Aug 26 '14 at 14:44
  • 2
    After creating your own keyboard shortcut make sure to logout. When you log back in the shortcut will start working. – hansgoed Aug 29 '14 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.