2

This question already has an answer here:

I just upgraded to Ubuntu 14.04 and I can't use my old keyboard layout configuration.

I used the Caps Lock key to change the layout to Hungarian. and I used the Shift+Caps Lock key to change the layout to English.

How can I set this keyboard shortcut in Ubuntu 14.04? All I can do is a previous source and next source option in All settings -> Keyboard -> Shortcuts -> Typing. But I don't know which was selected in most case, so I prefer start hit caps-lock before writing Hungarian, and Shift-CapsLock when I start programming. But now I can just rotate this sources (layouts) which is non-sense to me. I am not a finite state machine to remember my keyboard layout state.

marked as duplicate by Rmano, karel, Warren Hill, Radu Rădeanu, Eric Carvalho Apr 30 '14 at 11:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

One way you can do that, is by using the Gnome Tweak Tool. To install, Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install gnome-tweak-tool

Once installed, search foe tweak in dash, and click on it to open. Once opened, click on Typing, and then choose the Caps Lock behavior.

enter image description here

  • Doesnt work for me. But there is an option in Switching to another layout, that is selected for me (Caps Lock to first layout, Shift Caps Lock to second) but nothing happens after selecting that – Industrial-antidepressant Apr 29 '14 at 19:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.