23

I've installed Ubuntu 14.04. My wifi occasionally disconnects and I have to turn it off then back on to get wifeless again.

I am using Centrino Wireless-N 1030.

27

Also, make sure that power management is turned off.

iwconfig wlan0

should display a line with Power Management: Off. If it says On, you have to run:

sudo iwconfig wlan0 power off
  • This was exactly what was happening for me – Saad Farooq May 13 '15 at 3:27
  • 2
    Saved my life and nerves, thank you. Linux = 0 user experience. – Anis Abboud Oct 15 '15 at 18:32
  • 4
    To turn off permanently, follow the instructions in this related answer: askubuntu.com/a/129634/160673 – Planky Dec 17 '15 at 19:49
5

It seems to be due to buggy N mode of the driver, you can disable it e.g.

modprobe -r iwlwifi && modprobe iwlwifi 11n_disable=1

See more details here and here:

Btw I upgraded from 12.10 to 14.04 and was facing this problem, but once I re-installed I don't see this problem.

  • 1
    Actually, I think you can use swcrypto=1 instead of 11n_disable=1 and then you don't have to sacrifice the wireless n speeds you most likely paid good money for. – mchid Feb 4 '16 at 2:23
3

I used to have the same problem. Using modprobe to deactivate the fast n and ac type connections was not an option as my notebook is connected to a local network and needs high network speed.

A kernel upgrade from 3.13 to 3.18 has fixed the problem in my case. Now reliably using fast "n" connection with 300+ mbit/s (wifi adapter: Asus USB-53N, OS: Ubuntu 14.04.1). No disconnects anymore :-)

2
sudo iwconfig wlan0 power off

This solves the problem temporarily.

To make it permanent, add a configuration file:

cd /etc/pm/power.d
sudo -H gedit wifi_pwr_off

This will open an empty file, copy the code below into it:

#!/bin/sh 
/sbin/iwconfig wlan0 power off
  1. Save the file, remember to

    sudo chmod u+x wifi_pwr_off
    

    and restart.

Please note that instead of wlan0 it can be wlan1 etc for you. You can see interfaces with ifconfig, for example.

1

You may need to disable power_save mode in iw as iwconfig is somewhat depreciated. Run the following command:

sudo iw dev '$(iwgetid 2>/dev/null | grep -o "^\w*")' set power_save off

'$(iwgetid 2>/dev/null | grep -o "^\w*")' gets your device name, wlan0, wlan1, etc. so that you don't have to look it up or type it in. This makes it convenient to use as an alias or script.

If you know the device name, wlan0 for example, the following command does the same thing:

sudo iw dev wlan0 set power_save off
-1

This worked for me:

OPTION 1

sudo modprobe -r iwldvm #otherwise iwlwifi refuses to stop
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1
sudo modprobe iwldvm

OPTION 2

sudo modprobe -r iwldvm #otherwise iwlwifi refuses to stop
sudo modprobe -rv iwldvm
sudo modprobe iwldvm 11n_disable=1
sudo modprobe iwldvm
  • please add some explanation what this command does. – CyprUS Feb 12 '17 at 18:16

protected by Community Aug 29 '17 at 15:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.