Copy.com is a commercial service offering free space (much like Dropbox and, once, UbuntuOne). Starting with version 13.10 and continuing with 14.04, two bugs plague the Copy.com application on Ubuntu (see this thread):

  1. sometimes, the application indicator is not at all visible
  2. even if it is visible, the menu is not readable (no menu entries except for one or two), like this:

enter image description here

How can I get rid of these two bugs?

Update: a work-around was added in the Copy client so the instructions below are no longer needed if you use the latest Copy!

The Copy.com client indicator menu doesn't work properly in Ubuntu 14.04 and 13.10 due to a bug in libdbusmenu.

This bug was fixed in Ubuntu 14.10 and I'm not sure when it will be fixed in older Ubuntu versions but you can get the Copy.com indicator menu to work right now in Ubuntu 14.04 and 13.10 by using the fix / work-around below.

First of all: be sure to delete Copy versions eventually installed manually.

Then:

cd /tmp
wget https://github.com/hotice/webupd8/raw/master/libdbusmenu-gtk-$(arch).tar.gz
tar -xvf libdbusmenu-gtk*
sudo cp /tmp/libdbusmenu-gtk*/* /PATH/TO/COPY-FOLDER/

The instructions above will download libdbusmenu-gtk compiled with the fix and copy it to the copy-client folder. For the last command, replace "/PATH/TO/COPY-FOLDER/" with the path to where you've installed Copy. If you've used the Copy PPA, the path is /opt/copy-client/

This work-around / fix includes libdbusmenu-gtk built by me. If you want to build it yourself, see HERE.

via WebUpd8

  1. For the bug #1 (lack of the indicator): the reason for this appears to be that ever since 13.10, the systray is missing in Unity (see this question). In short, one needs to replace Unity with a modified version. This repository seems to work in 13.10, but did not work with 14.04 for me. For trusty (14.04), I found this repository usable: ppa:gurqn/systray-trusty

    sudo apt-add-repository ppa:gurqn/systray-trusty
    sudo apt-get update
    sudo apt-get upgrade
    

    (Source)

  2. Second bug is tricky and seems to appear on x86_64 architectures only. It turns out that it is due to a single setting in the configuration file in the local copy configuration folder. It can be easily modified, but requires the sqlite3 package to access the sqlite configuration file of copy.

    First, kill or otherwise close Copy. Then, in terminal, do the following:

    sudo apt-get install sqlite3
    cd $HOME/.copy
    echo 'UPDATE config2 SET value=0 WHERE option="csmBlackWhiteIconsV2" ;' | sqlite3 config.db
    

This should repair your menu.

EDIT: although the above seems to be a correct solution for at least a couple of users with a x86_64 system, clanlaw below (who uses 32b) reports that the change made his copy indicator disappear completely. Here is how to revert to the original setting:

echo 'UPDATE config2 SET value=1 WHERE option="csmBlackWhiteIconsV2" ;' | sqlite3 config.db
  • 1
    Firstly I do not understand how some using copy on 14.04 do not suffer from the missing indicator, but just the missing items in the dropdown. If the reason for the missing indicator is that it requires the systray, how is it that I see it ok? Secondly I have just tried the db value change and it has made the indicator disappear completely. What value should I revert it to in order to get the indicator back? – clanlaw Apr 29 '14 at 13:41
  • I do not fully understand the systray, but from what I understand, you should not have a visible indicator of Copy in 14.04. None of my machines has a visible indicator w/o adding the repository with modified Unity. Are you using x86-64? – January Apr 29 '14 at 13:50
  • You have your terminology mixed up. The indicator is visible regardless of whether you use that PPA or not. The legacy tray icon however, is only visible if you use the PPA, and yes it works because it is not an indicator! – RolandiXor Apr 30 '14 at 6:29
  • I can confirm that it doesn't work with Ubuntu 14.04 x86-64. At first when I installed the CopyAgent I had no indicator of whatsoever. I had to install libappindicator1 and libcanberra-gtk-module and to make the ~/.icons directory as pointed in my thread. The solution involving installing a modified version of Unity from a PPA is not the right one. – pr.nizar Apr 30 '14 at 12:51
  • @pr.nizar that is interesting, on 32 bit 12.04 I see that both libappindicator1 and libcanberra-gtk-module are installed and that I have a .icons directory. libappindicator1 is a dependent of tomboy apparently. Don't know why libcanbera is installed. I don't remember installing it. – clanlaw Apr 30 '14 at 13:03

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.