2

All of a sudden, when I log in to Ubuntu 14.04, I have no top menu bar, no launcher, no dash, only my desktop. Shortcuts like alt-F2 don't work either. Logging in as guest works worked fine.

At first I tried the ubuntu-tweak-tool tips laid out here, and ran unity-tweak-tool --reset-unity. The only effect, though was that Unity stopped working for all accounts! I also tried the compizconfig-settings-manager mentioned in many threads, with no effect.

I also tried reinstalling ubuntu-deskop and unity.

Don't know if it's relevant, but if I log in as guest, do ctrl-alt-F1 to open a terminal, log in as my user, run `startx' to open another gui session, and then try starting Unity from the terminal, it says “Invalid MIT-MAGIC-COOKIE”.

Also, ~/.xsession-errors has a lot of error like this:

 AccountsService-WARNING **: SetInputSources call failed: GDBus.Error: org.freedesktop.Accounts,Error.PermissionDenied: Not Authorized

What else can I do to troubleshoot?

The following workaround will give most of Unity (not the top menu bar) back around 50 % of the times, but only for the current session: Switch to terminal, and then

export DISPLAY=:0
unity-tweak-tool --reset-unity
unity
  • possible duplicate of Unity doesn't load, no Launcher, no Dash appears – karel Apr 29 '14 at 12:22
  • Well, the issue is the same, but I have tried every single solution mentioned in any of the answers, that is still relevant for 14.04. Don't know if that makes it ok to start a new, 14.04 question? – leo Apr 29 '14 at 12:48
  • Yes, it's OK to start a new question in case there is anything that has changed in Ubuntu 14.04 that is why all the answers to the linked question did not work. – karel Apr 29 '14 at 14:02
0

Turns out the solution was to purge and reinstall fglrx*, where obviously some setting had gone wrong:

sudo apt-get remove --purge fglrx*
sudo apt-get install fglrx
  • 2
    Note: This is only applicable to AMD Radeon. – Nicolas Raoul Mar 18 '16 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.