8

VLC suddenly stopped working, this is what I get now when I try to run it:

main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
main interface error: option qt-volume-complete does not exist
skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
skins2 interface error: cannot instantiate qt4 dialogs provider

I tried reinstalling multiple times, and there is no other program using the qt4 libraries. Also, the command line interface doesn't appear to do anything. When I try to "force" the qt4 interface, I get:

main interface error: no suitable interface module
main libvlc error: interface "default" initialization failed

ldconfig -p | grep libQt:

libQtXmlPatterns.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtXmlPatterns.so.4
libQtXml.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtXml.so.4
libQtSql.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtSql.so.4
libQtScript.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtScript.so.4
libQtNetwork.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtNetwork.so.4
libQtGui.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtGui.so.4
libQtDeclarative.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtDeclarative.so.4
libQtDBus.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtDBus.so.4
libQtCore.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtCore.so.4
libQtCLucene.so.4 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libQtCLucene.so.4
11
  • How about you try this: vlc --reset-config --reset-plugins-cache – Parto Apr 29 '14 at 11:53
  • It still gives the same error. I also tried to remove everything vlc and qt4 related (including cached info) and install again (I tried with Synaptic, with sudo apt-get install vlc and even with compiling vlc from source code). – Ioana Apr 29 '14 at 11:58
  • Though it seems like a problem with the qt-plugins and not VLC.. – Parto Apr 29 '14 at 12:15
  • Any idea how to solve this? – Ioana Apr 29 '14 at 12:17
  • I think there are some packages you installed recently that included some qt libs. Please provide the output of ldconfig -p | grep libQt – Parto Apr 29 '14 at 12:27
4
+25

I also once got the following:

main interface error: no suitable interface module
main libvlc error: interface "default" initialization failed

what I did was:

  • Purge all VLC related packages. Not delete but purge. In the example below there could be some packages missing from the purge list:

    sudo apt-get purge vlc vlc-data vlc-plugin-pulse vlc-nox
    

    If you are missing VLC packages simply do an apt show vlc or apt-cache search vlc but I recommend aptitude because of the friendly level compared to apt which is better: aptitude search vlc or aptitude show vlc. Both will show the packages, the former will show what packages you actually have installed. Remove those.

  • After you have removed ANY trace of VLC then make sure you don't have any conflict between 2 or more repositories that offer the VLC package or make sure you do not have an Alpha, Beta, Snapshot PPA that offers daily or not tested VLC packages. Type software-properties-gtk and it should open the Repository manager. Select Other Software and start looking in there for any VLC like PPA. Disable it or remove it.

  • Lastly go to /var/cache/apt/archives and remove all DEB packages (This is the cache folder for downloaded packages). This will make sure that when you tell apt to install the vlc packages again, it won't take the cache one but will download a new/working one instead. By doing sudo rm -fr *.deb INSIDE the /var/cache/apt/archives folder you will remove all deb packages in it.

  • After doing all 3 steps mentioned already, do a sudo apt-get update followed by an sudo apt-get upgrade. Wait until all repositories are updated and everything was updated and then do sudo apt-get install vlc. If you want, before installing VLC again, reboot PC to make sure no process, symlink or anything is still lurking around. I am being a bit paranoid here but the time this problem happened to me I followed 2000 tutorials to solving it. None work.

0
1

If all those trials didn't, why not try installing it from Ubuntu source package:

  1. Download build dependencies then source

    sudo apt-get build-dep vlc
    apt-get source vlc
    
  2. Build then install (--prefix=/opt/vlc to install it separately)

    cd vlc-2.1.2/
    ./configure --prefix=/opt/vlc
    ./compile
    sudo make install
    
  3. Run:

    /opt/vlc/bin/vlc
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.