I have installed Ubuntu 12.04 on Dell N4050. But there is a problem with my internet. It first works fine. But after sometime about 3 to 4 min, it stop working.

I tried to ping with server, default gateway and google, it ping with DNS but doesn't ping with the other 2. If i disconnect from wifi or LAN and connect again, it start working without any problem, But after sometime, same thing happen.

Before this, I installed 14.04, but there were some problem. I have windows 8 in parallel and the internet is working fine on it.

I have following network controller:

mhassan@mhassan:~$ lspci -nn | grep 0280
09:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)

And some time, packet misses when I ping - like 4 sent but 3 recieved.

Can any body help me to solve this problem?

  • 1
    It is solved now. There was problem in my Internet setting. The setting of subnet which i was using perhaps has another ip address as i was using. So i wrote just DNS server in setting and after that i check in which subnet i got ip address. So i change ny subnet and ip address. So now both wifi and eth are working fine....
    – user275790
    May 16, 2014 at 6:05

1 Answer 1


Solution/fix and it's a permanent.

Type in command line:

sudo modprobe ath5k nohwcrypt
sudo sh -c "echo 'options ath5k nohwcrypt' >/etc/modprobe.d/custom-wireless.conf"
  • Explain why does this help.
    – enedil
    Jul 7, 2014 at 12:44
  • I have no idea why it happens, just know entering the code fix it
    – SignedAdam
    Jul 21, 2014 at 11:12
  • I got slow speeds after entering the fix for "Wifi cutting out" so I then entered the following codes to fix "the slow speeds" $ sudo rmmod -f iwlagn $ sudo modprobe iwlagn 11n_disable=1 $ sudo su # echo "options iwlagn 11n_disable=1" >> /etc/modprobe.d/iwlagn-disable11n.conf $ sudo su # echo "#disable ipv6" >> /etc/sysctl.conf # echo "net.ipv6.conf.all.disable_ipv6 = 1" >> /etc/sysctl.conf # echo "net.ipv6.conf.default.disable_ipv6 = 1" >> /etc/sysctl.conf # echo "net.ipv6.conf.lo.disable_ipv6 = 1" >> /etc/sysctl.conf
    – SignedAdam
    Jul 21, 2014 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.