3

I am running Ubuntu 14.04, and I've installed windows 8 on virtualbox. The problem is that it is too slow - even minimizing a windows takes 2-3 seconds.

The reason I think this is a problem is because I have a fairly strong machine here: my cpu is i5-3470, and I have 8 Gigabytes of DDR3 running on intel SSD with SATA3. Checking the hardware monitor while running the VM shows that I only use 4 Gigabytes and CPU usage is around 5% idle.

Here's what I think: I have an on board graphics card that can't run all of windows' eye candy fast enough. Also, in virtualbox preferences I can't check 2d/3d acceleration, as I get a message about invalid configurations.

Am I right? And if not, any suggestions?

Thanks!

  • I'm guessing you mean the built-in HD 2500 graphics on your CPU? Can you be more specific about the error about the 2D/3D acceleration? – Nattgew Apr 29 '14 at 15:54
0

Your CPU integrated card should be enough to run Windows 8 eyecandy.

The fact that you can't check 2d/3d acceleration makes me wonder if you have too little memory allocated to the virtual video card.

Try to increase it in the Display section at the virtual machine preferences menu. Make it at least 256 Mb if possible.

enter image description here

0

VirtualBox acceleration requires both the host and guest to have the correct functionality installed. In addition, 2D acceleration is only available if you specify the Guest OS to be Windows. This means you'll need Host DKMS in Linux, and Guest Additions in Windows. For other functionality, you may want to add yourself to the vboxusers group, and restart your machine.

To install DKMS, install virtualbox-dkms and then reboot the machine:

sudo apt install virtualbox-dkms

To install Guest Additions, you need the image, and to provide that image to the Guest on a ROM drive. To get the image, visit VirtualBox Website, or use apt:

sudo apt install virtualbox-guest-additions-iso

The specifics are available on the Ubuntu Wiki.


Once these are available, and you've selected Windows as the guest OS, you'll be able to select 2D or 3D acceleration. If you chose one, or both, and see a warning, hover your mouse over the warning to read what's causing the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.