9

I am trying to install cpuminer according to this tutorial. The tutorial describes installing cpuminer using terminal.

sudo apt-get install libcurl4-openssl-dev libncurses5-dev pkg-config automake yasm

# clone cpuminer
git clone https://github.com/pooler/cpuminer.git

# compile
cd cpuminer
./autogen.sh
./configure CFLAGS="-O3"
make

# choose a miner pool and register there

# start the miner
./minerd --url=your.minerpool.org --user=username --pass=password

I have installed git and downloaded `cpuminer from git. but when tried to compile it I got this error:

user@user-Dell-Notebook-PC:~$ cd cpuminer
user@user-Dell-Notebook-PC:~/cpuminer$ ./autogen.sh
./autogen.sh: 8: ./autogen.sh: aclocal: not found
user@user-Dell-Notebook-PC:~/cpuminer$ 

I am new to Ubuntu and mining.

  • What do you get when you type aclocal on the terminal? – jobin Apr 29 '14 at 8:04
6

It looks like you are missing package automake. To install it open Ubuntu Software Centre and search for automake.

The clue comes from

./autogen.sh: aclocal: not found

The script autoget.sh (which is part of the miner) is trying to use the program aclocal which was not found.

To find out which file belongs to what package use these commands in a terminal window (once only):

sudo apt-get install apt-file
sudo apt-file update

Search for packages containing the program aclocal:

apt-file search aclocal
| improve this answer | |
  • @smurf hey thanks it worked but now its showing another problem when in tried to login to mining pool its showing this error bash: ./minerd: No such file or directory . any idea how to solve this – Eka Apr 30 '14 at 0:47
  • this means that a bash script is trying to start program minerd from the current directory but there is no such program. Find out where the newly compiled minerd resides (command is 'find ~ -name minerd -type f`), change to that directory and try again. – sмurf Apr 30 '14 at 23:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.