7

I've upgraded my Ubuntu from 13.10 to 14.04 using the Ubuntu suggested option, everything went well -- meaning no report of corrupted update or anything - but when I rebooted and logged in again there was no desktop, meaning all I was getting was a black screen and the mouse pointer. I looked through the other threads on here and tried the solutions on there, it didn't really worked.

All I've been able to do was after removing and re-installing the lightdm manager I was able to get the top bar in the logging screen, but after actually logging in with the default user I only get a top bar with File Wiew Help etc and I can't open a terminal using Ctrl AtlT. I had some special compiz configuration in 13.10, but I've removed it and the problem is still not solved. Another thing, if I log in with a guest user I get both the top and side bar in Ubuntu.

If you guys have any idea what I could do it would be appreciated.

L.E.

Thanks for your input but none of them helped sadly.

Dpn I tried to do what you suggested and I couldn't run the first command, I got the following error:

 Error: cannot autolaunch D-Bus without X11 $DISPLAY

And, Daniel your solution didn't change anything at all, I already had that files in the place with configured exactly as you suggested.

Is there a way for me to copy the settings from the guest account in the default account? Or a way to compare the 2 configurations and see what's different?

Thanks, any advice would be appreciated!

L.L.E. I fixed it, I don't know if it helps anyone but, what I did was to reinstall the compiz-core:

sudo apt-get install --reinstall compiz-core

and then to remove the files in the .cache and .config folders

sudo rm -rf ~/.config/dconf/user
sudo rm -rf ~/.cache/compizconfig-1

Hope this helps others!

Thanks for the support!

0

2 Answers 2

1

ITs because your lightdm is crashed. Do the following things

Press ALT+CTRL+F1

You will get tt1

Login as username = root

Password what you set for you system

Now enter the following lines

vim /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf.dpkg-bak //an editor opens b4 u

Delete what is there and add the following lines

[SeatDefaults]

greeter-session=unity-greeter

user-session=ubuntu

greeter-show-manual-login=true

Also edit the following file

vim /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

[SeatDefaults]

greeter-session=unity-greeter

user-session=ubuntu

greeter-show-manual-login=true

Now Restart the system using the following command

init 6 //Reboot system

0

Press Alt+Ctrl+F2, black screen appears.Now, login with your username & password & type this

dconf reset -f /org/compiz/

then

setsid unity

then Press Alt+Ctrl+F7 to see your desktop

Guest User will show default settings because its a different user. Every user has its own settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.