I upgraded to 14.04 and have managed to break by graphics drivers. I'm not even sure where I'm at now.

I have a Dell Studio 15 with a ATI Radeon 4500 video card. I know this is no longer supported by the latest proprietary drivers, so if I'm not mistaken I can just use the default xserver drivers (xserver-xorg-video-radeon)??

After my system upgrade I was able to login, but only when using the Recovery option from my grub menu (and just selecting the first option to continue to start up). I only had low resolutions available to me (up to 1024 instead of 1366) and everything was very slow. So I tried installing different drivers, and even tried the ubuntu-amd-catalyst-install from http://www.thefanclub.co.za/how-to/ubuntu-amd-catalyst-install, but that made things worse and has destroyed X for me.

How can I recover from this, and get things running nicely again?

I've tried to reinstall xserver-xorg-video-radeon but it fails with a dependency problem (xorg-video-abi-15, which is part of xserver-xorg-core). I try to install xserver-xorg-core and it tells me "reinstallation of xserver-xorg-core is not possible, it cannot be downloaded"

  • 1
    Please, do not add [SOLVED] to the title and do not add solution into the body. Instead, answer your own question and accept it once it will be allowed. – Danatela Apr 29 '14 at 7:53

The problem was solved by the OP (original poster). I'm posting it in order to keep site cleaner.

Well, I think I have fixed my problem right after pasting:

I did

sudo apt-get remove --purge xserver-xorg-*

followed by

apt-get install xserver-org

rebooted and was able to log in, even with full resolution.


You need the 13.1 AMD driver, this link works for the 32bit system


  • Legacy hardware (pre HD5000) is not supported any more, see this answer – bain May 27 '14 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.