2

I installed both Korean and Japanese using the Language Support window, and expected Korean (Hangul) and Japanese (Anthy) to show up in the input sources for Text Entry Settings (having both packages installed). However, neither shows up.

  • Have you found a solution? Have same problem :-( – e2-e4 Jun 23 '14 at 4:45
5

The comments in Writing Japanese with Ubuntu 14.04 Trusty Tahr suggest the following workaround:

I was not able to add the Anthy text entry in Ubuntu 14.04 using Gnome Fallback. Then I switch to Gnome Shell and I add it. Finally I switch back to Gnome Fallback and I can use it now.

I encountered the same problem after upgrading from 13.10 to 14.04: The Text Entry dialog in gnome-control-center does not list Japanese (Anthy), only plain Japanese and several others. Using the former, Super + Space (which previously was Ctrl + Space in 13.10), only toggles between the default keyboard layout (German for me) and English, but Anthy doesn't enable, even though it can be selected in the language selector applet (and then works and can be disabled once via keyboard, too).

For another user of that system, the toggling was still working, so I compared the configuration using dconf-editor. Under org.gnome.desktop.input-sources, I changed [('xkb', 'de'), ('xkb', 'ja')] to , [('xkb', 'de'), ('ibus', 'anthy')], logged out and in, and it worked!

| improve this answer | |
  • +1, this helped me, and because I wanted to use ibus-m17n instead of ibus-anthy (for Devanagari input), I was also helped by the instructions here: uglyduckblog.wordpress.com/2015/01/20/… Thanks so much! – ShreevatsaR Feb 21 '15 at 1:36
  • a huge problem/bug with using ibus + gnome fallback – prusswan May 21 '15 at 8:14
  • helped also on Artful Aardvark. – tkruse Jan 19 '18 at 11:38
1

Finally found a solution.

It appears that login through Gnome Classic, Metacity, Compiz etc... prevents Text Entry to work correctly. It ignores Japanese (anthy) for instance.

This is what I did

  • logged out
  • logged back in using the regular "Ubuntu" mode (unity)
  • Opened Settings then Text entry
  • added the IM of choice (eg "Japanese (anthy)") which became available!
  • logged back in using "Gnome classic" mode

Done.

| improve this answer | |
0

Several people have had similar problems. My solution was a reinstall with no internet, then connect and add in the inputs and languages (for me the inputs were there doing it this way even before I added in the languages). I was not able to get those entries to show once the problem cropped up.

Pls have a look at this, hope it helps: https://askubuntu.com/questions/456177/locale-language-bug-in-14-04-install-in-foreign-country-then-ibus-options-unav

| improve this answer | |
  • 1
    Your solution didn't work for me either. – bb94 May 2 '14 at 5:07
  • Really! You reinstalled, no internet? And did you check your text input options right after? For me I checked that first, and found the options I wanted, so I def didn't delay to get them in there. Then installed the language. But that was Chinese. – RhZ May 2 '14 at 6:57
  • What options do you see there? Did you check before installing the languages? Checking my options right now, (with only Chinese installed) I have many Japanese options, but not Anthy, and only one Korean option, it was like 101/104 compatible. – RhZ May 2 '14 at 6:58
  • Also, check your text input options prior to installing the language, see if you can get lucky as I did, and then also consider to download the input method you want prior to installing the languages...pls notice when those options change...this is a serious bug I think. I am making a new thread and we may want to file a bug report. – RhZ May 2 '14 at 7:02
  • Ok I made a new topic to hit this issue squarely. If I was you I would make a new topic as this one is "answered" and won't get that much attention. I would also reference your two languages in the title, (Japanese and Korean) as people using these languages will come out of the woodwork to share their own experiences when they see "their" language in the title. – RhZ May 2 '14 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.