7

I'm pretty new to ubuntu, or linux for that matter, and I'm trying to perform the simplest activity ever, copy and paste a file; for some reason, when I right-click the folder /usr/bin I see that the 'paste' option is gray (meaning I can't select it).

Why is that? I'm pretty sure I'm the ROOT User. I can see "Account type = Administrator" on the account's settings.

4 Answers 4

8

You're not the root user; you are a user which has the privilege to become root, using the sudo (or various graphical surrogates) method.

In Ubuntu (and in most not-embedded Unix environment) you normally work, and have the privileges, of a normal user. Only deliberately you can override the normal rules; it is a way of telling you that you have to know what you are doing. It is a great safety net that works normally quite well(1).

For example, although it can have legitimate uses, trying to add manually a file to /usr/bin is normally wrong.

You can find all the info you need here: https://help.ubuntu.com/community/RootSudo

(1) although remember that Unix, in general, gives you rope(2) if you really want to hang yourself.

(2) You can run the file manager application as root, as explained in the other answer.

Alas, you shouldn't.

This is the rope I mentioned in (1). A wrong click, a spurious double click, and you can have a completely messed up system, to the point of having to reinstall it. I am a power user, and I have to use root powers maybe... once a week? And most of the time is just to install some program, which you can do easily via the graphical application.

You should be able to do all of your work in normal mode; copy and paste between places you own works perfectly with the graphical interface. Why and what are you trying to copy to /usr/bin?

4
  • 1
    So, the GUI is completely useless? :/ I mean, copying and pasting is a pretty common action, I have to write the whole thing down every time I want to do so? :/ not very practical.
    – frankelot
    Apr 29, 2014 at 3:42
  • 1
    It's common sense a user should not be able to modify the system files, even if you use sudo you are in a risk of wrongly deleting something important from the system even when all you wanted was to modify a single icon or image.
    – xangua
    Apr 29, 2014 at 4:12
  • 3
    @feresr why useless? You can copy your executables in your ~/bin directory, where they will be found and executed, as if they where in /usr/bin/ --- and the GUI will let you do that. Out of the box. And if you mess things up, you can recover your system because you are messing up only your user, not all the system. I do not know how to explain this in a clearer way...
    – Rmano
    Apr 29, 2014 at 4:40
  • @feresr You can copy and paste in the GUI, but not in the system directories. When messing with system directories it's better to take your time since a wrong action could lead to the complete ruin of the whole system. In other words the time taken to do the task manually running sudo et al shouldn't really matter because you should be taking your time doing that stuff anyway. If you prefer to ruin your system you can always activate the root account and use that as if it was your normal account. Then don't blame the OS when you'll have ruined your system/lost all your data.
    – Bakuriu
    Apr 29, 2014 at 11:13
6

run this command in terminal:

sudo nautilus

nautilus is the filemanager in ubuntu if you are using it to copy/paste your files where you need root access you need to run your filemanager as root

5
  • See my comment below. I get that it is good practice to have some actions protected by a root user, but copying and pasting?. Do I have to do this every time I want to use the file explorer?.
    – frankelot
    Apr 29, 2014 at 3:43
  • 1
    not every time , only when you are trying to copy/paste into protected places or places your user/group dont have access to ...still you can set nautilus to run as root by defualt but i dont recommand that
    – k961
    Apr 29, 2014 at 3:46
  • 1
    especially copying and pasting is something that should be done only with great care when you're root.
    – Shadur
    Apr 29, 2014 at 6:49
  • Makes sense now. Thank you guys! really appreciate it
    – frankelot
    Apr 29, 2014 at 11:41
  • 2
    BTW, if you really want it, sudo -H nautilus is safer --- it avoid wrighting configuration files under your home as root.
    – Rmano
    Nov 17, 2016 at 17:46
1

If you are using a dual boot machine with windows, then properly this is the problem. on windows power settings, turn off fast start-up and hopefully, the problem will be solved. If it's already turned off, then make sure you have closed windows properly and not just sleep or hibernate. enter image description here

6
  • Well, It is not about how old the question is, StackOverflow is like an encyclopedia now, and I use the answers to many questions that are from 7 years. Regarding windows information, it is as I said in the answer: "if you are using a dual boot machine with windows". Aug 19, 2021 at 15:19
  • And what about the unrelated answer? Your comment is not answering the question.
    – Unix
    Aug 19, 2021 at 15:20
  • My answer was the solution that worked with me to the asked question, Moreover, there is an upvote from someone who found it useful. Aug 19, 2021 at 15:22
  • It's not the right answer and let me doubt about the legitimity on this upvote. In a dual-boot computer, an operative system installed on one partition has zero effects with the other operative system installed on the other partition. Moreover, there's zero evidence about what you are saying. And let me tell you something: I'm 100% sure that this did not help you, never. Probably what you did is a reboot, so you got a clean startup with your normal user. You know that? Correlation does not imply causality.
    – Unix
    Aug 19, 2021 at 15:29
  • @Unix the answer is correct. Keeping Fast Startup enabled in Windows will mount Windows partitions in Ubuntu in Read Only Mode. The solution is to disable it from inside Windows.
    – user68186
    Aug 19, 2021 at 15:30
0

you can execute this command from terminal. Set your drive name sudo ntfsfix /dev/

1
  • This would not work if the NTFS partition was mounted as read-only 🤔
    – matigo
    Jan 23 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.