5

As the title says, booting will occasionally give me an error saying something along the lines of "radeon: ring 0 test failed" followed by "radeon: disabling GPU acceleration" and then freeze right there.

I can't manually reproduce it, as it seems to happen randomly. When it does happen, I generally force it off by holding the power button, because the few times I've tried to let it work itself out, it stayed there for a couple hours. Sometimes it only happens once, other times it will continue saying the same thing for hours on end.

Once it stops happening, it will usually be fine for a couple of days, and then come back as soon as I start to forget about it.

Google has only turned up vague bug reports for other distributions that didn't even have a definitive answer. They repeatedly ended with the OP saying "nevermind."

I've been using Ubuntu for years and never had this problem. It only showed up when I made the switch to 14.04. Also, I didn't use the upgrade button. It's a clean install.

I'm running 64-bit on an HP Probook 4530s with hybrid graphics.

P.S. I know I said I've been using it for years, but there is still a lot I don't know. Even if you think it should be obvious, stick to baby-steps, just in case it's something I haven't run into before. My knowledge only goes as far as what I've needed to fix in the past, which isn't much.

Thanks for your time.

2 Answers 2

3

I had the same issue with my laptop, a HP Probook 4530s with a ATI graphic cards. I'm also on Ubuntu 14.04.

I could solve my problem by doing this :

Add this line to your /etc/rc.local file, before "exit 0":

   echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

And add this to /etc/modprobe.d/blacklist.conf

blacklist fglrx
blacklist radeon
alias radeon off
alias lbm-radeon off

It will disable your ATI discrete graphics card, this way you won't have any problem with Radeon when booting your laptop. Personally, my laptop works perfectly without the discrete card, I can use blender without problem for example.

6
  • I have a similar problem with my hp pavilion dv6. I suspect that I have an actual hardware problem, because my win 7 refuses to boot as well. Roky974's solution managed to solve the problem for me (actually to work around it, but that's ok for now..).
    – yaron160
    Sep 7, 2014 at 15:25
  • @yaron160 I am also facing same problem on my ubuntu 16.04 and windows 10. Could you tell me if you found any permanent solution to this problem ? I am fearing my GPU is having some problem. I have Dell Inspiron N5010
    – WSS
    Mar 23, 2018 at 15:43
  • @WSS, unfortunately I did not find a solution to the problem. My gpu actually died, so I had to disable it completely both in windows and ubuntu. Fortunately my laptop has also a built-in intel gpu, so I could continue working with it.
    – yaron160
    Mar 24, 2018 at 18:25
  • @yaron160 Thanks for replying. How did you know your gpu died ? Did you take it to repair shop ? May be there was a problem with display cable, I am curious to know . My laptop had heating issues in the past may be that cost my gpu.
    – WSS
    Mar 24, 2018 at 18:50
  • @WSS, I knew my gpu died because all of a sudden windows didn't boot either. To boot windows I had to plug out AC so windows will choose to work with the "low performance" gpu (the onboard one); only then I could disable the other gpu. I remember reading somewhere that in some laptops, if they heat too much, the gpu solderings evaporate and then it has contact problems. It was suggested that a soldering "reflow" process can solve the problem. Eventually, I needed my computer up and running and I was afraid I'll kill it completely if I'll start fiddling with it, so I let it be.
    – yaron160
    Mar 25, 2018 at 20:01
1

I have exactly the same laptop, and bumped into that problem in Ubuntu 14.04. It seems that it's the fault of the open source driver for ATI graphic cards in Ubuntu 14.04.

I did these things and got rid of it:

  • In BIOS settings I unchecked "Enable GPU switching" (something like it, don't remember exactly the label).
  • Restarted and this time got past that problem, but Unity only showed the desktop and icon and no Launcher and decorations. This problem is solved by following this post.

NOTE: These are the steps that I think they solved my problem; because I was struggling for 3 hours and doing many things. I tried to use ATI's proprietary drivers (using Additional Drivers in Ubuntu). They didn't work and I removed them. I even installed the driver I downloaded from ATI website (which was working fine in my previous Ubuntu 12.04), but it didn't work either. I reinstalled ubuntu-desktop and Unity and many other things that I don't remember exactly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.