20

I have a new Sager NP2650 laptop with a fresh Ubuntu 14.04LTS install. It has a Realtek RTL8723BE wireless adapter in it. Initially after installation I had no wireless, but I was able to get it working after following the instructions on this thread: http://ubuntuforums.org/showthread.php?t=2205497 . I had to checkout an earlier version of the driver from git as the thread says in order to get it to compile on my system.

The problem is that the connection eventually is lost within an hour or so, although Network Manager still shows it as connected. If I disable and re-enable the Wi-Fi or Networking it doesn't work. The wifi just endlessly tries to connect, but fails.

If I reboot it works fine again for a while.

I ran the wireless diagnostic script found elsewhere on the forum and uploaded my results here:

http://pastebin.ubuntu.com/7355768/

I could use some help. Thanks!

closed as off-topic by Braiam, Radu Rădeanu, mikewhatever, Mitch May 5 '14 at 12:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Radu Rădeanu, mikewhatever, Mitch
If this question can be reworded to fit the rules in the help center, please edit the question.

12

I have same problem. For me, work-around is to remove and reinsert rtl8723be module:

root@lenovob5400# rmmod rtl8723be && modprobe rtl8723be

Sure it's not a solution, but better than rebooting. What a shame Ubuntu does not work with such popular wifi card.

BTW, I tried kernel 3.15, but it has same issue (and few others).

Looking forward for better solution. Go get it hackers! ;-)

Update:

Friends, please vote on related ubuntu bug.

Update 2:

Upcoming ubuntu kernel 3.13.0-25.47 have #1240940 bug fixed, however, after installing this kernel from ppa, the rtl8723be module is there indeed, but I was not able to connect at all. Currently I am using standard 3.13.0-24-generic kernel with rtl8723be kernel module from: https://github.com/lwfinger/rtl8723be.git at 604aa9058fb9e5bb1cf571c99989d081f8fc8b9b commit.

Update 3:

I tried ndiswrapper 1.9 with winxp 64 drivers (and man others). All failed to load:

[  327.503426] ndiswrapper version 1.59 loaded (smp=yes, preempt=no)
[  327.517958] ndiswrapper: driver netrtwlane (Realtek Semiconductor Corp.,08/02/2013,2010.5.0724.2013) loaded
[  327.519049] ndiswrapper (NdisWriteErrorLogEntry:188): log: C0001388, count: 1, return_address: ffffffffa05e5d9f
[  327.519052] ndiswrapper (NdisWriteErrorLogEntry:191): code: 0x605
[  327.519143] ndiswrapper (mp_init:211): couldn't initialize device: C001001E
[  327.519146] ndiswrapper (pnp_start_device:395): Windows driver couldn't initialize the device (C0000001)
[  327.519150] ndiswrapper (mp_halt:254): device ffff8800cd747880 is not initialized - not halting
[  327.519151] ndiswrapper: device eth%d removed
[  327.519380] ndiswrapper: probe of 0000:04:00.0 failed with error -22

I tried one more trick - added fwlps=0 parameter for the rtl8723be module. So far so good. We will see...

  • Thanks for your input and sharing that 3.15 didn't help. Someone with the same problem and another realtek card suggested sudo modprobe -r [module name] && sudo modprobe [module name] so I tried that once when the WiFi went down, with no luck. I haven't tried rmmod instead, but don't they do the same thing? I'll give it a try next time it happens. I'm not on that laptop as often as my desktop. Yes, it is a shame. I guess we'll have to be patient. – themaninthewoods May 1 '14 at 5:12
  • modprobe -r rtl8723be should do same thing as rmmod rtl8723be since no other module is using it. I am not 100% sure this always works. It worked for me last time I had this problem. I will share my observations here if I find anything interesting. – Michał Šrajer May 1 '14 at 17:15
  • my wifi just dropped and yes, sudo rrmod rtl8723be && sudo modprobe rtl8723be did get it running again. Thanks! I'll try the fwlps=0 parameter next and let you know. Was that on 3.13.0-24? – themaninthewoods May 2 '14 at 5:38
  • 4
    I tried the fwlps=0 parameter and so far so good! I've been up for about 24 hours now with no drops! For others who want to try this, I used the command echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf Let me give it one more day and I will accept your answer. Very helpful! After doing some digging it looks like other realtek cards have needed similar modifications. See archlinux post and ubuntuforums post – themaninthewoods May 4 '14 at 22:20
  • 2
    Adding fwlps=0 parameter for the rtl8723be module worked for me too. Thanks for the fix. – Frank Barcenas Dec 7 '14 at 16:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.