29

I tried the solutions in tuxguitar doesn't play any sound but they didn't help.

I don't see Timidity as an option of the midi port. I can play midi files through timidity.

How can I debug this further?

Thanks, Andy

2 Answers 2

58

I had the same problem, and I solved it this way:

sudo apt install tuxguitar-alsa tuxguitar-jsa tuxguitar-oss

after this, go to Tools->Settings->Sound and select Gervill as Midi Port.

2
  • Just like to note that this also fixed the issue on Ubuntu 15.04, using the JACK audio server with the pulseaudio-jack-module. Of course I don't think JACK had anything to do with the issue, I believe it was just not playing nice with PulseAudio until installing the tuxguitar-jsa package.
    – KoRnKloWn
    Jul 18, 2015 at 19:19
  • 5
    Installing via apt rather than apt-get has a surprisingly colorful progress bar.
    – conorsch
    Jul 23, 2015 at 1:57
6

In my case the problem arose after update to 14.04LTS. Apparently tuxguitar-alsa was the problem. I removed that package and tuxguitar started working fine again.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.