I followed instructions and other instructions too but because it is not user-friendly, the ftp server is not working.

# This option specifies the location of the RSA key to use for SSL
# encrypted connections.
#user ddns address
pasv_address=54.... (my ip)
#choose and range you like


~$ sudo service vsftpd status
vsftpd stop/waiting
ubuntu@ip:~$ sudo service vsftpd restart
stop: Unknown instance: 
vsftpd start/pre-start, process 9711

But it can not connect with an ftp client. I opened the ports in security group and reinstalled everything, still not working. What can be done? What can't it work per default? I try to connect with a user account that I added with useradd.

$ sudo vsftpd
500 OOPS: munmap

$ service vsftpd begin
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service vsftpd begin

The script you are attempting to invoke has been converted to an Upstart
job, but begin is not supported for Upstart jobs.
  • 1
    This appears to be the same issue I'm having. Still no solution though. – roydukkey Apr 30 '14 at 1:40
  • 1
    @roydukkey I gave up and switched to proftpd and that works. – Niklas R. Apr 30 '14 at 8:20
  • What instruction did you use? – roydukkey Apr 30 '14 at 14:11
  • @roydukkey It was easy. apt-get install proftpd and then some edit to the .conf file and then the ftp server works. I hope you too can get it running. – Niklas R. May 1 '14 at 6:51

You've already answered your own question, but I'll go ahead and put this here for others who've come here.

Use proftpd, as @Programmer-400 mentioned, and don't bother trying to resolve the vsftpd. I looked into it and it seems that for ubuntu 14.04, there's a bug somewhere deep in some related library, which hasn't been resolved yet.

apt-get install proftpd

Installed without issue, also uninstallting vsftpd along the way. Configuration is just as simple.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.