1

I use Lubuntu 14.04 LTS and time keeps changing on me. At first it was set to internet sync, I chose my country, but apperantly the time there is wrong because it was 3 hours back. I also tried to set it to sync manually to close countries that use the same time zone, they are all 3 hours back from what they should be. [GMT instead of GMT+3]

I then changed it manually from the time and date settings and locked it, that works but only until the computer is restarted, and then it goes 3 hours back on it's own >.>

Edit: Yes I am dual booting with Windows

  • 2
    Are you dual booting with Windows? – Nattgew Apr 28 '14 at 19:33
2

By default Windows uses local time in the bios for eh, reasons. Most other operating systems use UTC, and display as the appropriate local time.

Clearly you need to change one to match the other.

To change Lubuntu: (note for readers in the future, this is reasonably likely to change soon to match some other distros, don't downvote me in a years time!):

sudo gedit /etc/default/rcS

This opens a file with a bunch of system variables. Find the line that says UTC=yes and change it to say UTC=no. Save. Reboot.

To change Windows:

Run regedit. Navigate to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation. If there's a value called RealTimeIsUniversal (value 0) change it to 1. If not, create a new DWORD value called RealTimeIsUniversal and set the value to 1. Reboot.

To decide which to change:

The pros for going UTC (the Linux/Unix/OSX/Android/iOS/nearly everything else way) are that it makes more sense generally, not least because UTC doesn't change about like local times can, and there are lots of little bugs that can be caused by using local time in the background.

The pros for going for local time (the Windows way) is that MS don't support the registry setting described above.

If you're mostly a Windows user and are just trying Lubuntu or have a few things you like it for, or Lubuntu is for enjoying computers while Windows is for the stuff you earn your bread with, then I'd recommend keeping Windows as it is, and changing Linux to match.

Otherwise, I'd recommend changing Windows to work the Linux way.

  • Now, if I could just work out why I unexpectedly had the exact opposite problem last night... – Jon Hanna Apr 28 '14 at 21:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.