I know that other, multiple questions have been posted on this, but I'm fairly certain I've applied most, if not all, of the suggested solutions, and I'm no closer to resolving this issue.

I am running Ubuntu 12.04 (Black Opal, 32-bit system, Firefox web browser), and I cannot use any website that provides flash video (e.g., YouTube). The page loads, but the typical black box with the "play" icon does not load...that area is completely white/blank. This is true of all other Flash sites.

I made sure I have the ubuntu-restricted-extras package installed, and I even tried installing the flashplugin-installer ... in fact, according to Synaptic Package Manager, I have that AND flashplugin-downloader installed. Interestingly, I also have adobe-flashplugin version, which would seem to be correct (I know that support for Flash in Linux ended with 11.2) and both adobe-flash-properties-gtk and -kde (whatever those are). Also, it appears that none of the previous Firefox helper-extensions for flash in Linux are available any longer. I have no idea where to go from here, and being able to see flash websites is occasionally a necessity for me.

As an interesting related note: Google Chrome/Chromium (I can't remember which) was installed as part of my Ubuntu system install, and I seem to remember it working...until I installed the flashplugin-installer to try and fix my problems with flash...now, Chrome doesn't even load! Double-clicking on the icon produces no response. Looking in the system monitor, I can see instances of Google Chrome are invoked when I double-click the icon, but there is no visible effect (no browser window, etc.)

Running Google Chrome from terminal shows:

[0428/183027:ERROR:nacl_helper_linux.cc(236)] NaCl helper process running without a sandbox! Most likely you need to configure your SUID sandbox correctly.

At the same time, I got a popup window that told me System Problem has been detected (or something to that effect) and asked if I wanted to report it, etc, etc.

What did I do wrong, or what am I missing? Thanks in advance!


The last Flash version provided by Ubuntu repos is 11.2.

To get latest Flash version 13, the easiest way is hrough Google Chrome browser.

Unfortunately the Pepper Flash Plugin of Chrome doesn't work with the default Ubuntu browser, Firefox.

You should reinstall Google Chrome:

sudo apt-get install --reinstall google-chrome

You may uninstall the old flashplugin-installer because it is obsolete.

sudo apt-get purge flashplugin-installer
  • Thanks for your response, @Cornelius. Unfortunately, this did not work. After the reinstall, Chrome behaves exactly as it did before: double clicking on it will create an instance in System Monitor (as well as an instance of "chrome-sandbox"), but there is no visible effect (Also, I got rid of "flashplugin-installer"). I'm really not looking to upgrade to Flash version 13: version 11.2 is just fine with me; I simply can't get it to work at all!
    – Superion
    Apr 29 '14 at 4:09
  • @Superion Seems like this issue is specific to Athlon XP processors code.google.com/p/chromium/issues/detail?id=318646 and productforums.google.com/forum/#!topic/chrome/5EmprHC36WU . What processor do you have?
    – Cornelius
    Apr 30 '14 at 10:36
  • Hello @Cornelius. I was able to find some of the same information you found. I did some research and found I DO have an AMD Athlon processor...model 2800+ (estimated). Unfortunately, I haven't been able to find a solution. One poster in a forum mentioned, "Oh, well, back to Firefox"...but I cannot get flash to work with that, either!
    – Superion
    Apr 30 '14 at 19:41
  • At this point, based on my research and other threads, I've even tried using an older version of Flash's libplayer.so file, placed in usr/lib/mozilla/plugins (or something like that)...that solution also failed. Does anyone else have any input? I'm running out of options, and this is a critical feature for me..._surely_ Linux/Ubuntu has some way of doing this!
    – Superion
    May 2 '14 at 14:55
  • Hello @Cornelius: do you or anyone else have any additional input or suggestions? I have not been able to resolve this.
    – Superion
    May 5 '14 at 20:23

Only this plugin did the trick !


  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Mitch
    Dec 22 '14 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.