0

Just installed Ubuntu 12.04. The default display driver has fixed my resolution to 1024x768. The only other option I see for selection is 800x600. Is there a way to increase my resolution to see 1280x800 as many sites recommend? My desktop is not using the full screen. It's sticking to the left side. Have about 4 inches of dark unused area to my right.

Have been trying to configure this since 3 days. No progress made so far :-(

As per some of the suggestions in the comments, I tried the following steps.

Step 1: cvt 1280 800
Output: 

# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHzModeline "1280x800_60.00" 83.50 1280 1352 1480 1680 800 803 809 831 -hsync +vsync

Step 2: xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

Step 3: xrandr --verbose --addmode LVDS1 1280x800_60.0
Output: 
X Error of failed request:  BadMatch (invalid parameter attributes) 
Major opcode of failed request:  149 (RANDR)
Minor opcode of failed request:  18 (RRAddOutputMode)
Serial number of failed request:  27
Current serial number in output stream:  28

Is this due to refresh rate? My xrandr gives the following output now:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

1024x768       60.0*+
800x600        60.3     56.2
640x480        59.9

VGA1 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)
1280x800_60.00 (0xd5)   83.5MHz
h: width  1280 start 1352 end 1480 total 1680 skew    0 clock   49.7KHz
v: height  800 start  803 end  809 total  831           clock   59.8Hz
  • Do you know which GPU your laptop has ? – NGRhodes Apr 28 '14 at 18:36
  • 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) – Naveen Karnam Apr 29 '14 at 13:05
0

ONLY If installing drivers for your GPU doesnt help. [Should be at Software & Updates >> additional drivers] Try looking here : How to make my maximum screen resolution to be detected by Ubuntu? Look at the answer provided by Venki I had the same problem and that helped me. But on the first command instead of :

cvt 2048 1536

I used:

gtf 1280 1024 60

gtf [horizontal res] [vertical res] [refresh rate]

If you get odd looking fonts after following the linked post, use :

sudo add-apt-repository ppa:no1wantdthisname/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fontconfig-infinality

Not sure if that package above will help but it did help me. If it doesnt you can uninstall it by: sudo apt-get remove --purge fontconfig-infinality sudo ppa-purge ppa:no1wantdthisname/ppa

  • cvt 1280 800 .. didn't help too. – Naveen Karnam Apr 30 '14 at 12:55
  • Hmm dude I think you have a typo. Looking at your post I see: --newmode "1280x800_60.00" but when you did --addmode you typed 1280x800_60.0 missing a 0 , I hope that's the problem. Sorry it took me this long to reply ;s – Kyodo May 1 '14 at 8:06
  • Hi Kyodo! Thanks for checking back. I tried with an extra 0. I get a similar error. "X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 149 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 27 Current serial number in output stream: 28" – Naveen Karnam May 2 '14 at 14:35
  • xrandr --fb 1280x800 does this work ? – Kyodo May 2 '14 at 15:06
  • It doesn't go beyond 1024x768. No effect even if I give bigger values. – Naveen Karnam May 2 '14 at 16:05
0

12.04 additional drivers should offer an Nvidia driver for your geforce 6150 gpu, The one to use is current, driver 304.117. Then you can use the "Nvidia X server settings" program to adjust the resolution to 1280x800. In 14.04, the drivers are found under the "software and updates" program's 4 tab.

  • My graphics controller is : 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) – Naveen Karnam Apr 29 '14 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.