1

I have had no problems with the audio on my Dell Inspiron 15 1700 since I had purchased it a month ago. However, today the audio from my laptop's internal speakers no longer works. It was working last night. I left my laptop open over night, and when coming back to the keyboard this morning the speakers no longer worked.

My headphones still function perfectly, though. My system is also a dual boot win8/ubuntu. The audio works just fine in Windows 8 still.

Can someone please assist me in enabling the audio on my internal speakers again?

I have tried the following:

sudo apt-get remove --purge alsa-base alsa-utils alsa-oss pulseaudio
sudo apt-get install alsa-base alsa-utils alsa-oss pulseaudio
sudo alsa force-reload
pulseaudio --kill
pulseaudio --start

dump of /etc/modprobe.d/alsa-base.conf

#autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-    blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

This is the output I get when running sudo alsa force-reload

Unloading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-rawmidi snd-seq-device snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer (failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
Loading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-rawmidi snd-seq-device snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer.

output of uname -r:

3.13.0-24-generic

output of sudo aplay -l:

**** List of PLAYBACK Hardware Devices ****
Home directory not accessible: Permission denied
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

output of lspci -v | grep Audio:

00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)    
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)

Alsamixer screen:

enter image description here

When trying to run the HDA utility, I get the following error:

Traceback (most recent call last):
  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 546, in <module>
    sys.exit(main(sys.argv))
  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 523, in main
    if read_nodes(sys.argv[1:]) == 0:
  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 89, in read_nodes
    read_nodes2(c.card, i)
  File "/dev/shm/hda-analyzer/hda_analyzer.py", line 60, in read_nodes2
    c = HDACodec(card, codec)
  File "/run/shm/hda-analyzer/hda_codec.py", line 1041, in __init__
    self.parse_proc()
  File "/run/shm/hda-analyzer/hda_codec.py", line 1140, in parse_proc
    self.proc_codec = HDACodecProc(self.card, self.device, file)
  File "/run/shm/hda-analyzer/hda_proc.py", line 479, in __init__
    self.parse(proc_file)
  File "/run/shm/hda-analyzer/hda_proc.py", line 677, in parse
    node.add_digital(line[11:]) 
  File "/run/shm/hda-analyzer/hda_proc.py", line 296, in add_digital
    self.wrongfile('unknown dig1 bit %s' % repr(b))
  File "/run/shm/hda-analyzer/hda_proc.py", line 143, in wrongfile
    raise ValueError, "wrong proc file format (%s)" % msg
ValueError: wrong proc file format (unknown dig1 bit 'KAE')

UPDATE 1

I have tried booting into an ubuntu 12.04 nad 14.04 live cd's, and the audio does not work there either. This is really confusing as up until last night the audio functioned perfectly for my laptop. The audio still continues to work just fine in windows 8.

  • Install pavucontrol and see if that tells you more: sudo apt-get install pavucontrol. Be sure to scroll all the way down. – Jos Apr 28 '14 at 14:12
  • have it installed already. here is a screenshot of all the tabs imgur.com/a/6qRyc – user196195 Apr 28 '14 at 14:18
  • For an Intel HDA card, you can run the HDA analyzer utility. It has even more sliders and check marks to play with. – Jos Apr 28 '14 at 14:37
  • i tried running the utility with no luck, i have added the output of the error I get to my original post. – user196195 Apr 28 '14 at 14:47
1

I have a couple things for you to try.

First, see if this solution works for you. Here's a link to guide you through the steps.

If it doesn't (or if you already have it disabled), then click "This bug affects you" in this Launchpad bug.

  • That was me who posted that question, and their solution did work. Odd solution indeed, though. Thanks for getting back to me though! – user196195 May 17 '14 at 17:24
  • You're welcome! Glad to help. – Isiah Meadows May 19 '14 at 1:09
  • Hi, somehow Analog Output disappeared in sound options. My computer has only 14.04 and there is no Windows 8 installed. Do you have any idea to solve the problem? – Baskaya Aug 6 '14 at 23:42
  • Is it sometimes on, sometimes off, with it usually off? If so, please see my answer (and links). – Isiah Meadows Aug 6 '14 at 23:51
0

I had similar issue. I had installed both Win 8.1 and Ubuntu 16 on Lenovo E570. But in my case on any of those 2 OS i could not see Audio device of built in speakers only HDMI audio device as in your case.

What surprisingly solved this issue for me was to hard turn off the PC from windows by pressing power off button and holding it for at least 30 seconds. I assume there was some temp failure of hardware which was fixed by running totally out of power.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy