I have a custom xkb symbols file which looks as follows:

// modify the basic German layout to have polish characters
default partial alphanumeric_keys
xkb_symbols "basic" {

    include "de(basic)"
    name[Group1]="Germany - with polish characters";

    key <AD03>  { [         e,          E,      eogonek,      Eogonek ] };
    key <AD09>  { [         o,          O,       oacute,       Oacute ] };
    key <AC01>  { [         a,          A,      aogonek,      Aogonek ] };
    key <AC02>  { [         s,          S,       sacute,       Sacute ] };
    key <AD06>  { [         z,          Z,    zabovedot,    Zabovedot ] };
    key <AB02>  { [         x,          X,       zacute,       Zacute ] };
    key <AB03>  { [         c,          C,       cacute,       Cacute ] };
    key <AB06>  { [         n,          N,       nacute,       Nacute ] };
};

The name of the file is depl. I copy the file to /usr/share/X11/xkb/symbols and it works with setxkbmap depl.

However, I also tried to add the respective menu entries in the "Text Entry" customization. I have modified the file /usr/share/X11/xkb/rules/evdev.xml and added the following section:

<layout>
  <configItem>
    <name>depl</name>
    <shortDescription>depl</shortDescription>
    <description>German (with Polish characters)</description>
    <languageList>
      <iso639Id>ger</iso639Id>
    </languageList>
  </configItem>
</layout>

I have then reconfigured the xkb data with sudo dpkg-reconfigure xkb-data.

It works in as much as that the new layout appears as a viable option in the Text Entry dialog, it can be added to the list of dialogs and is visible in the application indicator:

enter image description here

However, it does not work, the new symbols are not loaded. No errors are reported in /var/log/Xorg.0.log.

  • Could you try swap lines (order) include "de(basic)" and name[Group1]= – user.dz Jan 26 '15 at 10:12

each symbol file should have a default layout.

default partial alphanumeric_keys
xkb_symbols "basic"

hope this help

  • Thank you for your answer. I have added "default" to my file just before "partial". setxkbmap depl works, choosing from menu does not. – January Aug 19 '14 at 10:25

Read your post and many others online, while i wanted to modify my in Unicode layout.

Things worked well, except i have to restart my PC every time i make changed to layout file in symbols folder. I was looking for an idea just to restart xkb to see effects without restarting entire PC. Found it in README file. Executing sudo udevadm trigger --subsystem-match=input --action=change in terminal allows you to check your changed layout immediately, without restarting! I thought this might help you during you experiments.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.