I have many applications with tray icons like davmail, hardware monitor. I miss this feature on Ubuntu 14.04. Does anyone have a solution?

There are some tools like Skype indicator, but I need a general solution for this problem so that I can add application icons to the system tray.


15 Answers 15


You may need to do two things:

1. Install the sni-qt libraries.

Install sni-qt Install banshee (click on the link), or with sudo apt-get install sni-qt sni-qt:i386 from the terminal, and then restart Skype. The tray/panel icon should now be back!

The reason this step is required is because sni-qt is installed automatically by the Ubuntu repository Skype package, but NOT by the Skype deb you directly download. Once Skype 4.0 is in the Ubuntu repos, you can install from there and this will no longer be necessary.

2. You may also need to whitelist the indicator

We don't know why, but for some systems this additional step is required before the indicator will show (thanks to Bruno Pereira!)


  1. Install the package dconf-toolsInstall dconf-tools (click on the link), or from the terminal with sudo apt-get install dconf-tools

  2. Open dconf editor from the Dash (or dconf-editor from terminal):

    enter image description here

  3. On the left sidebar, use the triangles to navigate to desktop > unity > panel. On Ubuntu 12.10 you instead need to navigate to com > canonical > unity > panel. Double-click on the orange [JavaEmbedded...] part on the right, and add ,'skype' to allow the Skype indicator to show, as below:

    enter image description here

  4. Press Enter, close dconf editor, logout and login -- your indicator should now be back!

  • 9
    In Ubuntu 12.10 I found it at a different path within dconf-editor: com > canonical > unity > panel.
    – aecolley
    Oct 29, 2012 at 21:25
  • 2
    On Ubuntu 12.10 you do not have a panel item under unity. :( One Zero's answer works though.
    – Ali
    May 11, 2013 at 11:32
  • 4
    As of 13.04, both com > canonical > unity > panel and desktop > unity > panel are not there. IMO the right solution is to install skype from repository as described here Jun 8, 2013 at 9:03
  • 2
    Can confirm this works great on 13.10, and I didn't need to whitelist it. Just installing that package and quitting then starting Skype again fixed it :)
    – mystery
    Oct 31, 2013 at 22:44
  • 1
    In Ubuntu 14.04, I found I needed to change Skype with a capital letter to skype all lower-case before the icon was permitted. Skype with a capital had previously worked before I upgraded to 14.04 / Trusty. Apr 28, 2014 at 15:56

To have Skype Tray Icon displayed in Ubuntu, install sni-qt package:

sudo apt-get install sni-qt:i386
  • 1
    this actually made it work for me in 14.04 - and it is sni-qt:i386 not just sni-qt. (on my system (64 bit) skype is also installed as skype:i386). Perhaps it is the same problem for other apps.
    – sunew
    Sep 24, 2014 at 19:56
  • upgraded ubuntu from 12.04 to 14.04 (dirty install), skype tray icons disappeared. this fixed it
    – krukid
    Sep 29, 2014 at 9:38
  • 4
    More info on why this works: askubuntu.com/a/151118/48105. Oh, and don't forget to logoff/login (or restart unity) for this to take effect. Jan 10, 2015 at 13:42
  • 1
    On 14.04.01 I only needed to kill and restart Skype after installing sni-qt:i386. Works great.
    – amotzg
    Feb 18, 2015 at 15:46
  • 2
    Still the solution for 16.04 (sad to know the problem persits).
    – jgomo3
    Apr 25, 2016 at 18:13

Enable Skype Icon on Unity Notification Panel on Ubuntu 12.04 LTS

When you do a fresh install of Ubuntu 12.04 (Or any version with Unity for that matter), you install Skype and expect it to work as it used to. But if you close the main window - you soon notice that Skype icon is not being displayed in top panel.

To fix this you will need to run a few commands. So open up your terminal and run this:

gsettings get com.canonical.Unity.Panel systray-whitelist

You should get something like this:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier']

Basically this means, that Skype is not whitelisted, thus is not allowed by default to display its tray icon. We need to fix this. Append 'Skype' to the list so that you have something like this:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']

Then wrap it with double quotes (”) and add gsettings set com.canonical.Unity.Panel systray-whitelist in front of it. At this point you should have something like this:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

Now just copy this to your Terminal and execute the command. Reboot afterwards. Now you should see the icon.

Source: Enable Skype icon on Unity notification panel on Ubuntu 12.04 LTS - Tautvidas Sipavičius

  • Thank you for providing the commands b/c when I open DConf editor I don't see a Panel option under Unity. This worked well for me after I also installed sni-qt (not sure that was required).
    – kingdango
    Dec 21, 2012 at 13:12
  • 6
    After the first command: No such schema 'com.canonical.Unity.Panel'. Ubuntu 13.04 64-bit.
    – Hubro
    Jun 30, 2013 at 16:42
  • 1
    Same here: "No such schema" Ubuntu 13.04 64 bit Aug 15, 2013 at 6:52
  • Here: Systray on Ubuntu 13.04 webupd8.org/2013/05/how-to-get-systray-whitelist-back-in.html Aug 15, 2013 at 6:56

This is because Ubuntu has turned off whitelisting since version 13.10. Here are two options to fix:


sudo apt-get install libappindicator1


sudo apt-add-repository ppa:gurqn/systray-trusty
sudo apt-get update
sudo apt-get upgrade

For more information: System Tray icons not showing http://ubuntuforums.org/showthread.php?t=2217458 https://launchpad.net/~gurqn/+archive/systray-trusty

  • 5
    it doesn't work in 14.04
    – Ahmed Daif
    May 15, 2014 at 9:30
  • 2
    libappindicator1 on its own didn't work for me (from a clean 14.04 AMD64 install), but it worked after also installing systray-trusty (including the manual gedit step) AND restarting.
    – paulcm
    Aug 26, 2014 at 14:43
  • 1
    for Utopic, you should use ppa:gurqn:systray-utopic, if it does matter
    – Danatela
    Nov 24, 2014 at 10:35
  • Vivid version also available ppa:gurqn:systray-vivid Oct 27, 2015 at 9:27

I was facing this problem too. Installing following package solved my problem.

sudo apt-get install sni-qt:i386

I am on Ubuntu 15.10, sni-qt:i386 was required for the systray icon to show up.

  • This is the best solution for Ubuntu 14.04 LTS. The registry fix doesn't work. Restart Skype after installing sni-qt:i386 Jun 6, 2016 at 14:59

maybe you need to whitelist skype to the notification area (i'm not sure if skype includes an appindicator)

The easy way to make it is installing dconf-tools

sudo apt-get install dconf-tools

or Using Software Center Install via the software center

Then press alt+f2 and enter dconf-editor to see a program like this:


Navigate to desktop-->unity-->panel and add the apps that you like to whitelist to the end of the list (in your case you must add 'Skype') separate by comas. You can instead write all to whitelist all apps to use the notification area.

You will need to log out and log in again yo apply the changes.

More info: http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html

  • 1
    I don't see 'panel' under unity. Am I missing something? I'm on 14.04
    – itsols
    Nov 9, 2015 at 15:27
  • Probably the path have changed for 14.04, can't say for sure because I'm not using Unity right now
    – zurdo
    Nov 9, 2015 at 20:58

Here's what worked for me to get both the Skype and Franz indicator back under Ubuntu 16.10 64-bit Unity Desktop

1) I installed sni-qt:i386 as mentioned here with sudo apt-get install sni-qt:i386

2) I installed libappindicator as mentioned here with sudo apt-get install libappindicator1

3) Finally I installed the .deb package found at http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/p/pidgin-indicator/ via the software center. As mentioned here, this provided the final resolution.

  • Thank you so much for your efforts! Just a question: why do we need to install the Pidgin Indicator if we only need to fix Skype and Franz?
    – orschiro
    Nov 12, 2016 at 19:19
  • While I wouldn't doubt that the reason why could be found in the pidgin-indicator .deb package, all I know right now is it worked for me. Unfortunately I don't have the time to dig into it further at the moment.
    – Elder Geek
    Nov 13, 2016 at 0:19
  • My problem must be something else. Even after installing Pidgin Indicator, I still experience the problem...
    – orschiro
    Nov 14, 2016 at 10:23
  • That's odd, did you do all 3 steps?
    – Elder Geek
    Nov 15, 2016 at 18:58
  • 1
    This worked pretty well for me. At the first run Skype froze for some reason but from the second it started to work. Jan 5, 2017 at 17:07


Here I post you an article that explains how to include Skype in a Unity system tray whitelist.

I have Ubuntu 12.04, it worked for me!


Basically, open a new terminal and execute this:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

and then restart Skype.


If your are using gnome shell, activate this extension call Status Icon Fixer

Fixes Dropbox, Skype, vlc and others into the status bar; not perfect, but ok.


  • 2
    For Ubuntu 13.10 and newer, Status Icon Fixer reportedly does not work any more. I use the alternative Top Icons extension for 13.10 and it works well.
    – tanius
    Feb 17, 2014 at 17:55

For me the path in dconf editor was:

com -> canonical -> indicator -> appmenu -> messages

And then click on applications and in value add 'skype'. I'm running Ubuntu 13.10 (64-bit).

  • 1
    Did not work for 14.04 Trusty.
    – mcmlxxxiii
    May 27, 2015 at 22:38

A solution that works as of Dec 2015 in Ubuntu 14.04 is to install the following PPA:

sudo apt-add-repository ppa:fixnix/indicator-systemtray-unity
sudo apt-get update
sudo apt-get install indicator-systemtray-unity

This gives you an arrow in the taskbar that you may click to show your icons. You can also have the icons show in the bar itself and instructions for that can be found here: http://www.webupd8.org/2015/05/on-demand-system-tray-for-ubuntu.html

Why don't the other solutions work anymore? Updates to Unity keep breaking the other ppa solutions and it seems no one is committed to keeping them up to date.


Go to the Skype->Options.

In the General Category check "Start Skype minimized in the System Tray".

  • nope that didn't change anything. But the option is (in german) rather labeled start minimized (says nothing about the system tray). So now I just have to click two times on the button in the Launcher Jun 15, 2012 at 6:47

I'm using Gnome-Flashback (formerly Fallback/Classic) with a tint2 panel. I tried all of these fixes and none of them worked for me. I even tried

sudo add-apt-repository ppa:timekiller/unity-systrayfix
sudo apt-get update
sudo apt-get upgrade

No luck. Even tried killing tint2 and using the gnome-panel instead. Still no icons for many, but not all, of my apps.

I finally found a solution while looking for a way to get(specifically) the network manager to show in the systray here. Since I use Cairo-Dock as a launcher, I just changed all the launch commands for my apps that weren't showing up to dbus-launch app-launch-command. Where app-launch-command is the regular launch command for that app. Did the same for Startup applications and it works like a charm.


This solution works fine with Ubuntu 17.04

Simply run the application with "env XDG_CURRENT_DESKTOP=Unity". For example, to start Skype For Linux, you would use:

env XDG_CURRENT_DESKTOP=Unity skypeforlinux

To make the fix permanent, copy the application desktop file from /usr/share/applications/ to ~/.local/share/applications/, then edit the file and change the "Exec" line by adding "env XDG_CURRENT_DESKTOP=Unity" (without the quotes) immediately after "Exec=".

More details at http://www.webupd8.org/2017/04/fix-appindicator-not-working-for.html


I had the same issue. Here is what I did to correct it.

Open Terminal

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo shutdown -r now
  • Every solution doesn't comes with reinstall, atleast not in ubuntu. Sep 14, 2015 at 3:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .