I recently installed 14.04, and decided to do so as a fresh install.

I wiped the only Ubuntu installation on the system, left a Windows 7 installation on, and installed over mdadm (once with /boot on mdadm and later with it not on mdadm as that saves a few other headaches. I'm pretty sure what I'm describing happened in both cases).

Everything from previous Ubuntu installations were completely wiped by manual formatting of the relevant partitions.

I'm in a time-zone currently on Irish Summer Time (UTC+01:00). Windows started jumping the time an hour ahead.

Now, I might expect a default Windows installation to jump the time an hour back, thinking the UTC bios time was the local time, but this was an hour ahead and I had RealTimeIsUniversal set in the registry to get some saner behaviour out of Windows.

After some puzzling over this, I realised that in /etc/default/rcS there was the line UTC=no to set Ubuntu onto local time rather than the normal UTC=yes.

This is a well-known setting for people who normally only use Windows as the illogical choice of local time (not unambiguous) means less change for them than fixing Windows in a way that MS don't support, but I certainly didn't set it.

This was easily fixed, but as I don't know what broke it, I don't know that it won't be broken again.

Is there anything that sets UTC=no upon use or installation, and if so can that be blocked?


If you install Ubuntu on a clean disk with no other OS, UTC=yes is used as default. In your situation, you have Windows aside Ubuntu. So in the installation Ubuntu detected Windows and set UTC=no. Although your Ubuntu is clean, the disk is not clean.

| improve this answer | |
  • Well, that's pretty uselss if it's true. Does the same thing happen if there's a mix of Win and Linux? – Jon Hanna May 5 '14 at 22:18
  • @JonHanna I think it's a compromise. As Win and Linux have different time switching, you have to choose one as default. – snowhawkyrf May 7 '14 at 13:31
  • which I had done. It decided to do what most linuxes do not do, and I can't see that choice documented anywhere. – Jon Hanna May 7 '14 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.