I am running Ubuntu 14.04 and I am new to Linux and networking. I am having trouble with my ASUS N-13 network adapter, I get a signal but that signal drops often. What can I do?

  • Have you googled for, e.g. "Ubuntu Trusty USB-n13" and/or "Ubuntu USB-n13"? Chances are other people have had the same problem and already solved or reported it.
    – user41313
    Apr 28, 2014 at 5:15

2 Answers 2


If you're still looking for an answer to this, and for future users, there's a great solution which refers to the original solution.

I have just copied and pasted as is from the README:


Ensure you have the necessary prerequisites:

sudo apt-get update
sudo apt-get install git linux-headers-generic build-essential dkms

Clone this repository:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Set it up as a DKMS module:

sudo dkms add ./rtl8192cu-fixes

Build and install it:

sudo dkms install 8192cu/1.11

Refresh the module list:

sudo depmod -a

Ensure the native (and broken) kernel driver is blacklisted:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

And reboot. You're done.

  • 1
    This worked flawlessly on 16.04! Jan 8, 2018 at 22:13
  • 1
    If sudo dkms install 8192cu/1.10 won't work, check directory /usr/src/ for proper name (it was /usr/src/8192cu-1.11/ for me so I had to use command sudo dkms install 8192cu/1.11) Mar 4, 2018 at 20:09

usb-n13 is very finnicky on dual boot system. when i am using full time linux, rebooting directly to linux from linux session, the card will give me full 40Mbs internet speed. Similarly, if i reboot directly to windows from windows session, it will give me full 40Mbps. And if I were to boot from linux to windows session, it will be full speed too. But, if i were to reboot to linux from windows session, the speed will degrade to 1 Mbps. To fix it, i unplugged and replugged, it will be behave good again at 40Mbps. All said, this is a very good card when it works.

  • Try to disable fast boot in bios, and report it in answer if helps
    – LeonidMew
    Feb 3, 2019 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .