By default when you type in gEdit, mouse disappears and you can get it back by moving your mouse. So, you can do whatever you want using your mouse.

But when I press Shift or Ctrl or Enter and move the mouse to get the it back on screen, it won't work. The mouse will be shown when it's moved and suddenly disappears. So, I can't do any actions using it. This is a very weird bug. To get back the mouse, I have to right click on the editor.

Is this a known bug? How can I fix it? Has only gEdit (version 3.10.4) have this bug? Should I downgrade it to lower version?

I've tested this on leafpad Text Editor and this problem doesn't exist there.

2nd Bug

When you're typing for a while (like 30 minutes or more), sometimes gEdit won't allow typing anymore, but you can save the file and do other stuff. There won't be any cursor to make it normal again, you have to close the gEdit window and start new one.

As far as I tested, this "new gEdit" is way too buggy.

Is there any other lightweight (or not) text editors like gEdit with code markup and other stuff ?

UPDATE

When gEdit is ran in root (gksudo gedit), this bug doesn't seem to exist. So, why does this bug occur in normal user and not in root ?

  • Are you just pressing those keys once, or holding them down to cause the mouse to do this? – Nattgew Apr 28 '14 at 16:38
  • 1
    I'm experiencing this problem too after I use the Find command (Ctrl+F). If you run top in a terminal do you also find that ibus-daemon eats around 50% CPU. This problem started when I upgraded to Lubuntu 14.04. – August Karlstrom Apr 29 '14 at 16:20
  • @Nattgew When any of the keys are pressed once, this problem occurs. – Subin Apr 30 '14 at 17:01
  • If I start my window manager from a console (with startx) I don't have this problem in Gedit, so there must be some service/daemon that causes this. Maybe we can disable it. – August Karlstrom Apr 30 '14 at 20:44
  • 1
    Since the problem seems to be caused by IBus, a work-around is to disable it by setting Keyboard input method system to none in gnome-language-selector. – August Karlstrom May 15 '14 at 14:55
up vote 4 down vote accepted

This bug has not been fixed and I decided to switch to another text editor. I found Geany and it's great. It does not have the bug like that on gEdit.

So, I guess the solution is to switch to a new text editor until (or not) this bug is fixed.

Features of Geany

  • Lightweight
  • Have Basic Features of an IDE
  • Faster than gEdit
  • few dependencies
  • Supports many filetypes
  • Have Plugins & Code Markup (Syntax Highlighting)
  • Kind of like gEdit (Disable view of Sidebar & Messages Window)

UPDATE - Bug Fixed

As reported by August Karlstrom, The gEdit mouse bug was fixed when I disabled IBus as the default Keyboard Input System. Here's how you can disable it :

Open a terminal and do the command :

gnome-language-selector

A window named Language Support will open up. In the window, change the Keyboard input method system option to none instead of IBus and close the window. GNOME Language Selector Window

The changes would only take effect after you restart (reboot) your computer.

  • 1
    yes i too have tried it[Geany] and its flawless without any bug – agha rehan abbas May 8 '14 at 3:47

Just install ibus-gtk:

sudo apt-get install ibus-gtk

And open again your session.

source: https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1377370

  • This is the flawless solution if you wanna use gedit and ibus together. If it was up to me, this would be the accepted answer. – Xufox Mar 26 '15 at 19:10

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.