1

When updating a server from 12.04 to 14.04, a wrong press of ENTER lead me to disable SSH password authentication for root (One of the options it mentions while updating through SSH). The whole update procedure finished correctly but after rebooting the cloud node it shows the prompt for password in the terminal but the password is always wrong:

Permission denied, please try again.

How can I restore SSH connection to the server if the only way to access it was through SSH. Is there anything I can do client side to connect to the server via SSH again?

  • Not there is a way unless you've generated a key and stored locally on a client where you use to connect. If this is on the cloud you may have to check the control panel for any resetting options for the root password else have to contact for support. – AzkerM Apr 28 '14 at 7:41
2

This is a known issue in 14.04. The reason for this issue is described in the answer of What does 'without password' mean in sshd_config file?

Can you check it out?

0

Are there any user accounts on the system besides root? If so, you can SSH into one of the user accounts and use sudo. If not, I guess you'd need KVM access to login as root directly. If you can't do that, I guess you'll have to start over.

If you can, save the filesystem image so you can mount it later and access your files.

In the future, make sure you set up a user account with sudo permissions, and use ssh-copy-id so you can login with a key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.