4

I hope it's not improper to post a question about Thunderbird on here, but I didn't find their site too helpful.

The other day my Thunderbird stopped syncing with my email. I've tried everything I know to do (including re-installing Ubuntu) and I'm still getting a problem. Specifically, when I go to setup an account, I get to the last step and click "Done," but the account is never created because it is stuck on "Checking password..." When I first setup Ubuntu 14.04, it worked flawlessly, but now even after a re-install, Thunderbird is giving me this problem.

Plus, all of the information I have input into Thunderbird is correct.

3
  • May be its sort of configuration error with thunderbird. BTW reinstalling ubuntu was an overkill - Its the last thing you can do if at all something goes weird. Try this: sudo apt-get purge thunderbird It will remove thunderbird and all of its config files. After that, install thunderbird as usual, and check again. See if your caps lock is on while typing password. Apr 28, 2014 at 4:25
  • As Jay said, you're not in Windowsland anymore. Don't ever reinstall the whole OS for a problem like this again. ;) Having said that, you need to give more details: what kind of account, does it work in other email apps, how long has it not been working, etc. You need to do some basic troubleshooting.
    – user41313
    Apr 28, 2014 at 5:38
  • 1
    So, I fixed the problem. When I set up my proxy settings, I had specified a proxy for HTTP, HTTPS, FTP, and SOCKS. I removed the proxies for FTP and SOCKS and Thunderbird works perfectly fine now. You're absolutely right about it being pointless to re-install. I was only more obliged to do that because I had just installed Ubuntu 14.04 the day before.
    – bjd857
    Apr 28, 2014 at 6:14

2 Answers 2

1

I solved the problem by removing my proxy settings for FTP and SOCKS. I did this by updating my /etc/apt/apt.config file as follows:

Acquire::http::proxy "http://<username>:<password>@<proxy>:<port>/";
Acquire::https::proxy "https://<username>:<password>@<proxy>:<port>/";

I'm not sure why Thunderbird had trouble when I had the FTP and SOCKS proxy entered, so that would be an interesting question for someone to answer. For now though, I'm satisfied that the problem is fixed.

1
  • This worked for me too, in thunderbird's preference, configure proxy for only http and ssl, not socket. Then it works.
    – Eric
    Sep 29, 2016 at 3:01
0

I wasn't able to use the above answer because there was no apt.config file in the directory /etc/apt on my computer.

I was getting this error while trying to set up an existing Gmail account using Thunderbird. After launching the Mail Account Setup dialog box and entering my e-mail and password, I clicked on "Manual config" at the bottom of the dialog box and switched the authentication from OAuth2 to Normal Password for both the incoming and outgoing settings. I was then able to add the e-mail account to Thunderbird.

5
  • 3
    At the bottom of what? It seems pretty odd that you had no such file. What version of Ubuntu are you using?
    – Zanna
    May 6, 2017 at 1:30
  • @Zanna It's entirely feasible. See askubuntu.com/questions/34666/what-happened-to-etc-apt-apt-conf :-) I don't have a copy of /etc/apt/apt.config on my 14.04 asystem...
    – Elder Geek
    May 6, 2017 at 19:32
  • Thanks @ElderGeek :) I still don't understand what this answer is talking about though!
    – Zanna
    May 6, 2017 at 19:34
  • @Zanna Neither do I. Manual config at the bottom is a bit unclear at best (at least to me) I'll leave it to someone who actually uses Thunderbird to correct it as I`m not currently using it.
    – Elder Geek
    May 6, 2017 at 19:39
  • I added some details that hopefully made this answer clearer. The Oauth2 method doesn't seem to work with Gmail accounts and Thunderbird under Linux and Thunderbird just hangs when choosing this option. By trial and error I found the "normal password" option.
    – brettv
    May 7, 2017 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.