I just upgrade to ubuntu 14.04 and I see that the connect to another server via SSH is no longer part of the nautilus environment. Can anyone direct me how to re-enable this feature.

thanks, Wayne

  • 3
    ssh://user@ip doesn't work?
    – Alex
    Apr 28, 2014 at 0:24
  • The above comment, Jo-Erlend Schinstad's answer and user275419's answer below is correct. You should, therefore, mark pick one as the correct one to save people like me having to look for the correct answer. May 14, 2014 at 15:12
  • please mark your question answered. Mark the answer accepted, if it solved your problem.
    – Anuj TBE
    May 1, 2015 at 8:43

8 Answers 8


It is still there in "Files > Connect to ..."

Enter sftp://user@address/folder/ and you should be good to go.


open terminal

ctrl + Alt + T



Connect to server

Enter your ssh ip address:


Enter your username and password:


You are done: after successful login, you will see like this:

server folder

Hope this will help you.

  • Perfect!! This does work flawlessly! Mar 11, 2016 at 17:46
  • 2
    Ubuntu 20.04: nautilus-connect-server gives command not found
    – Tino
    Jun 17, 2021 at 13:40

The problem

When trying to access a remote filesystem via sftp in nautilus (enter ^L to access the location bar, entered sftp://user@host/export/dumps/client/user/ as uri, the current working directory gets prepended: /home/user/sftp:/user@host/.. and echoed in the error message(/home/user being the current working directory):

**Unable to find the requested file. Please check the spelling and try again.**
Unhandled error message: Error when getting information for file '/home/user/sftp:/user@host/...': No such file or directory.

Short Answer

At least on my system, it seems that sshfs was not installed during the upgrade to 14.04. Check if it is installed:

apt-cache policy sshfs

For me, installing it:

sudo apt-get install sshfs

fixed the problem. (You need to restart the entire gnome desktop for this to become effective, so you may just as well reboot after installing it if you're on a desktop system without concerns about downtimes and server functionality)

The menu point for accessing a remote server (which used to be in the File menu) is now visible in the left pane under Network - Connect to Server. It is also possible to enter a URI (sftp://user@server/path) into the location bar that gets displayed when hitting Ctrl+L.

Long Answer

I've been battling this problem from another angle (see [deja-dup ssh method doesn't work - writes locally instead][1]), and finding the reason for the mysterious misbehaviour took me into the depths of

  • gvfs
  • sshfs
  • fuse

Debugging process:

trying to mount via gvfs:

% gvfs-mount sftp://user@server/export/dumps/client/home/user
Error mounting location: volume doesn't implement mount

If the user is not the one running the current desktop, gvfs-mount needs to be prepended with dbus-launch:

dbus-launch gvfs-mount sftp://user@server/export/dumps/client/home/user

to be able to mount the remote directory. However, this doesn't seem permanent, so we're containing all our gvfs related stuff within one shell:

dbus-launch bash
gvfs-mount sftp://user@server/export/dumps/client/home/user
calibre@magrathea:~$ gvfs-mount -l
Drive(0): ST320LT020-9YG142
  Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Volume(0): 5,4 GB Volume
  Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Volume(1): Nexus7
  Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Mount(0): user on server -> sftp://user@server/
  Type: GDaemonMount
nautilus &

Looks like gvfs mounted the remote home directory of user instead of the requested absolute path. Same if /export gets an additional / preprended. Within the nautilus that got called in the last line, an URI pointing to the desired absolute path can be entered and mounted once the underlying problem is solved.

trying to mount via sshfs:

Additional dependencies (incomplete):

  • The user needs to be a member of the fuse group. Test with: grep <username> /etc/group, if he's missing: sudo usermod -a -G fuse <user>. With a passwordless group, the user needs to logout/re-login for this change to take effect.
  • gvfs-backend needs to be installed

(to be continued)

[1]: deja-dup ssh method doesn't work - writes locally instead. Check with apt-cache policy gvfs-backend


You can also enter:
ssh://IP address

For example:

The resulting dialogue box will ask for user name and password on the machine you are trying to connect to and give you options about how to remember the user name and password.


In newer versions of the Gnome file manager Nautilus (> Ubuntu 16.04), this feature has moved to a new location:

  • Open the file manager
  • Click Other Locations
  • At the bottom of the window you will see a connection dialog

Clicking the querstion mark will give examples on how to enter the server and what protocols are supported.

nautilus screenshot

  • Works, but I hate this! They ruined with our loved Nautilus! Backing to use Nemo (apt-get install nemo) on Ubuntu Bionic. May 29, 2018 at 13:19

You can do it with Nemo. Start by installing the dependencies-free version (open a terminal window with Ctrl+Alt+T and type):

sudo add-apt-repository ppa:webupd8team/nemo
sudo apt-get update
sudo apt-get install nemo nemo-fileroller

Launch Nemo and from the File menu select Connect to Server, this menu has the SSH option in server type.


The answer is

Enter your ssh ip address:


not ssh://youripaddress

  • 2
    As i remember, when you suply a ssh:// protocol handler it asumes that you have typed sftp. Did u even try before answer?
    – m3nda
    May 24, 2015 at 6:41

Please check your gvfs-backends package, first.

$ dpkg -l | grep gvfs-backends
ii  gvfs-backends

If it`s not exist, please install it.

$ sudo apt-get install gvfs-backends

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .