2

I've found questions on mapping a Windows share in Ubuntu, and an Ubuntu Server share on Windows, and Samba, and NTFS, and VirtualBox -- but I can't find how to map an Ubuntu share on another Ubuntu machine...!

  • I'm running 2 PC's at home, both plain-vanilla Ubuntu 14.04.
  • On both, some folders have been shared using Nautilus, right-clicking on a folder and choosing "Local network share".
  • In Nautilus, I can "browse network" and see the shared folders, but when I show the address (Ctrl+L) then it's like "smb://other-desktop/public/". My apps (specifically Beyond Compare 3) won't read that path.

How do I map a remote folder to my local filesystem tree??

Update: This post lists many ways to share. Surely, one among them is more recommended for normal users? I'm not looking for "datacenter-scale" solutions -- just something simple that I can explain to my wife :)

1

You're find a directory in your /var/run/usr area that you can link to something more readible.

For instance:

/var/run/user/1001/gvfs/smb-share\:server\=hera5\,share\=olympia/

Browse the /var/run/user and find the exact patch such as above. Make a folder that you can easily access and link it to that.

$ mkdir ~/myshare
$ ln -s /var/run/user/1001/gvfs/smb-share\:server\=hera5\,share\=olympia/ ~/myshare

Now you can access the folder with "ls ~/myshare"

By the way, you don't have to be super user to do this.

  • Wait, are you saying that "/var/run/user/1001/gvfs/smb-share\:server\=hera5\,share\=olympia/" is a valid path in the file system? – Torben Gundtofte-Bruun Apr 28 '14 at 13:21
  • Yes. It's a valid path. I link it to "~/myhera5" for convenience. If you follow the steps I provided for you, you'll actually see this first hand. Would you mind showing us what you find in your /var/run/[userid]/gvfs folder for the folder that you'll be conveniently linking for your wife? – L. D. James Apr 28 '14 at 16:05
  • there is no folder with my userid, nor literally "userid", in my /var/run/... there are samba/ and user/ dirs but they seem unrelated. I am confused! – Torben Gundtofte-Bruun Apr 29 '14 at 20:17
  • thanks, this gave me a valid path, but read-only. How do I make it writable? – Torben Gundtofte-Bruun May 11 '14 at 7:15
  • You should have the same permissions in this folder that you have when you found it in Nautilus' network browser. Are you saying the permissions are different? The permissions are defined when setting up the samba share. See your network administrator and ask them to give you (your login user) write access to the share. – L. D. James May 11 '14 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.