0

I have a Dell Vostro 2420 pre-installed with Ubuntu, now re-installed manually, but wifi stopped working, I tried some of the methods shown in other threads for similar problems. One of the method I tried is as per this thread: Wireless Not at all working, but wifi is still not working:

if I do `ifconfig` it shows the following
eth0      Link encap:Ethernet  HWaddr  
          inet addr:192.168.1.6  Bcast:192.168.l1.255  Mask:255.255.255.0
          inet6 addr: fe80::e2db:55ff:feaa:6a25/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3341 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2658691 (2.6 MB)  TX bytes:531140 (531.1 KB)
          Interrupt:41 Base address:0xc000 
eth1      Link encap:Ethernet  HWaddr  
          inet6 addr: fe80::9e2a:70ff:fed9:c6e9/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:3114
          TX packets:0 errors:11 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:927 errors:0 dropped:0 overruns:0 frame:0
          TX packets:927 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:86581 (86.5 KB)  TX bytes:86581 (86.5 KB)

and the following command shows:

$ rfkill` list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

I haven't got a clue about how to bring up the wifi. I'm awaiting a favorable solution so that I can connect to wifi without hassles.

  • 1
    Please do what is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Apr 27 '14 at 18:36
  • Hi @WildMan I have added the result of wireless-info.txt at pastebin.ubuntu.com/7353939 Is there a solution for this? can I still connect to wifi? any method to connect please suggest! – Emman Apr 28 '14 at 17:46
  • Please post the output of: modprobe -c | grep -i "14e4.*4365" – Wild Man Apr 28 '14 at 21:30
  • Hi @WildMan no go when I type the given command in terminal nothing is getting displayed! – Emman Apr 29 '14 at 19:01
0

That is what I thought, your device is not supportd in 12.04 without a lot of extra work.

When dell installed 12.04 on your system they added the driver and the pci id for the device that is why it worked when you first received it before you reinstalled.

The best thing to do is to install ubuntu 14.04 your device should work after installing the driver without issues.

  • Hi @WildMan Initially I tried intalling ubuntu 14.04 some drivers didn't worked that is the reason I installed back the ubuntu 12.04 from the link ubuntu.com/certification/hardware/201202-10593 Now I did sudo apt-get update and rebooted.. unbelievably WiFi is getting connected but one thing I want to ask is ifconfig is showing eth0 eth1 instead of eth0 and wlan0! But that should not affect my WiFi I guess – Emman Apr 30 '14 at 14:24
  • eth1 is what it is called when the wl driver is installed, if you were able to use the b43 driver it would be called wlan0. – Wild Man Apr 30 '14 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.